View Issue Details

IDProjectCategoryView StatusLast Update
0000685MediaMonkey (current)Main Panel/Toolbars/Menuspublic2021-01-07 16:15
Reporterrusty Assigned To 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version3.1 
Summary0000685: Duplicates functionality is unintuitive
DescriptionCurrently (MM 2.0) in the default configuration, hashes aren't calculated, and so when the user clicks duplicates, none are ever shown, and there's no warning indicating to the user that duplicates may exist but aren't shown because....

What should happen is:
-user clicks duplicates
-MM verifies whether hashes have been calculated for all tracks
--If they have, then duplicates are shown
--If the haven't been calculated for all tracks, then the following message appears:
X Tracks in your library have not been analyzed for redundancy. Would you like to analyze them now (this takes a fair amount of time)? [Yes] [No]
---If the user clicks Yes: Hashes are calculated for all tracks that do not yet have hashes (user must be prompted to enter CDs if they exist in the library). Once this 'scan' is complete, the results appear.
---If the user clicks No: Duplicates are shown for tracks that already have hashes.
Tagsdoc_help
Fixed in build1197

Relationships

related to 0002920 closedrusty MediaMonkey (current) Automated metadata lookup for tracks already in the DB 
related to 0000231 new MediaMonkey (current) Simplify Duplicate Tracks functionality 
related to 0005498 new MediaMonkey (current) Duplate analysis should occur as a background process & be enabled by default 
related to 0005800 new MediaMonkey (current) Duplicate Content Node Issues 
related to 0017334 closedlowlander MediaMonkey 5 Duplicate content functionality is broken for tracks analyzed in MM4 
related to 0017340 closedLudek MediaMonkey (current) Duplicate content functionality is broken in certain scenarios 

Activities

jiri

2003-09-06 13:08

administrator   ~0002273

Quite a good idea, we just need to consider that such dialog would pop up everytime, maybe that a check box for disabling it for the next time would solve this.

rusty

2007-04-16 19:21

administrator   ~0009015

We should also consider using fingerprints instead of hashes to detect duplicates.

rusty

2008-11-25 06:28

administrator   ~0015095

We should implement this as suggested, and in the future, we can add fingerprinting support.

Per Jiri's suggestion, the '[ ] Do not show this again ' option should appear in the dialog.

jiri

2008-11-25 08:55

administrator   ~0015105

Assigning to Ludek to implement as described. I would just leave that prompt for entering CDs - this would only cause problems and I don't think it would be really useful.

Ludek

2008-11-27 21:17

developer   ~0015203

Added as described in build 1196.

Note:
If user clicks [yes] then the background signatures calculating is started in a thread, but results are not shown at the end. The reason is that it can take hours to calculate all signatures and then it doesn't make sense to show results.

Ludek

2008-11-27 21:19

developer   ~0015204

Last edited: 2008-11-27 21:19

Re-opened, I forgot for the '[ ] Do not show again' checkbox.

stephen_platt

2008-12-04 03:47

developer   ~0015363

Verified 1199