View Issue Details

IDProjectCategoryView StatusLast Update
0005186MediaMonkey 4Playlist / Searchpublic2009-02-19 22:10
Reporterlowlander Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Fixed in Version3.1 
Summary0005186: Quick Search with "" (quoted strings) doesn't work as expected
DescriptionWhen using the quick search with "" MediaMonkey expects that the search results containing a leading/trailing space or no character.

"Flac" with path searchable should find all flac files, it doesn't
"adonna" should find Madonna if Artist is searchable, it doesn't
Additional InformationRelated forum topics:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35999
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35968
TagsNo tags attached.
Fixed in build1214

Relationships

related to 0005133 closedjiri MediaMonkey 4 Improved context help for Search bar 
related to 0005565 closedLudek MediaMonkey 5 Full-text search only finds prefixes (gives poor results in Oriental languages) 
related to 0005639 closedLudek MediaMonkey 4 Full text search yields poor results when searching for Drive paths 
child of 0003040 closedLudek MediaMonkey 4 Implement proper full-text search 

Activities

Ludek

2009-01-13 12:38

developer   ~0016173

Last edited: 2009-01-13 12:41

According to the 0005133 the spec says:

Search Tips:
A : finds tracks with A* or รก*
+A : finds tracks with A* only
"A" : finds tracks with A only
A B : finds tracks with A AND B
A OR B : finds tracks with either A or B
A -B : find tracks with A and NOT B
artist:A : finds tracks with Artist = A
year:X..Y : finds tracks in range X to Y
rating: X.. : finds tracks with X stars or more

So I don't know why "Flac" with path searchable should find all flac files and why "adonna" should find Madonna if Artist is searchable.
i.e.
A* means that A is prefix and "A" means exact match
Neither of these say that adonna should find Madonna.

I don't think this is a bug, it meets the spec.

lowlander

2009-01-13 15:01

developer   ~0016179

The issue than could be the double use of "". It's used to find only matching, but also to force inclusion of special characters. The current implementation doesn't allow for a user to search with forced special character inclusion if I'm not mistaken.

lowlander

2009-01-13 15:10

developer   ~0016180

It also seems that what I indicated is true as well. It does find partial matches as long as partial matches have a space leading/trailing.

"Flac" returned all tracks with /xxxx FLAC xxxx/ in filename, which would be incorrect per spec?

lowlander

2009-01-13 16:29

developer   ~0016182

Additionally "full path" searches return no result. Whereas this would be expected.

Ludek

2009-01-13 18:42

developer   ~0016186

Last edited: 2009-01-13 18:48

I see, I think that it works quite fine, it finds words like a full-text search engine, because it is full-text search engine, but we customized it in the way that finds prefixes of _words_.
i.e. It is ok that FLAC is found within /xxxx FLAC xxxx/, but should not be found within /xxxxFLACxxxx/.

Btw. If I input MP3 then it finds all my MP3s, because mp3 is part of path after . and . is replaced by space.
So I don't know why "Flac" with path searchable didn't find all your flac files.
(you might want to send me your DB so that I could reproduce).

Re: the note 16179:
Quoted strings finds exact matches, i.e. searching "help!" finds only fields including word help! (including the exclamation mark - not just help)
If you have an example that doesn't work then put it here.

jiri

2009-01-13 21:08

administrator   ~0016191

Problems with quoted strings reported in

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=36011

and

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=36047

Ludek

2009-01-14 12:50

developer   ~0016200

Last edited: 2009-01-14 13:10

All the "A" cases fixed in build 1214.
 
i.e.
1. searching for " - ", "-" works
2. searching for all the cases reported here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=36047 works.
3. searching "Flac" with path searchable finds all flac files.
4. additionally searching for "C:\" finds all files on the C drive as requested here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35968&st=0&sk=t&sd=a&start=15

stephen_platt

2009-02-19 22:10

developer   ~0016706

verified 1223