View Issue Details

IDProjectCategoryView StatusLast Update
0004938MediaMonkey 4Properties/Auto-Toolspublic2009-04-08 02:01
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Fixed in Version3.1 
Summary0004938: Make separator configurable for multi-attribute properties
DescriptionUsers have complained about the fact that the multi-attribute separator ';' isn't configurable. Per discussion, we should modify MM to make it configurable e.g.:

In Tools > Options > Library > Appearance (underneath 'Show Shortcuts')
[ ] Split multiple attribute fields with: _;_

Presumably, if enabled:
-Track scans that detect a ';' in a multiple attribute field would store multiple attributes.
-Tag updates would trigger the tag to be saved with multiple attributes
-Tracks that have split tags would display with the separator to denote the split
-Tracks that have a separator for multiple attributes but have not yet been tagged with multiple attributes should appear in the 'Unsynchronized Tags' node.
Tagsdoc_help, todoc_context
Fixed in build1202

Relationships

related to 0003844 closedpeke Last.fm plugin Last.FM Native Support 
parent of 0003014 closedrusty MediaMonkey 4 Improved input mechanism for multiple value fields 
related to 0005467 closedjiri MediaMonkey 4 Multi-attribute fields aren't displayed correctly in several different cases 
related to 0005528 closedjiri MediaMonkey 4 Multi-attribute field configuration: spacing is confusing 
related to 0005529 feedbackjiri MediaMonkey 4 Multi-attribute field splitter characters that aren't field splitters don't display consistently 

Activities

jiri

2008-11-25 13:15

administrator   ~0015109

Fixed in build 1193.

peke

2008-12-04 03:52

developer   ~0015368

Verified 1199

peke

2008-12-04 04:59

developer   ~0015373

- Custom Separator is not used in Scripting so SDB.player.CurrentTrack.ArtistName still shows ";" even Separator is changed to "/"

jiri

2008-12-04 11:45

administrator   ~0015376

This is on purpose this way - so that scripts don't have to worry about changed separator. In case the string should be presented to user, there are two new methods added to SDBTools object that help converting the string values back and forth.

rusty

2008-12-09 05:56

administrator   ~0015557

Minor tweak:

Split multiple attribute fields with:
--> Split multiple-value fields with:

Add context help:
--> This specifies what character is used to denote multiple values within a single field (e.g. Rock;Folk).

Note: functionality not yet tested.

jiri

2008-12-09 10:07

administrator   ~0015558

Fixed in build 1202.

Owyn

2008-12-15 03:10

updater   ~0015649

Options->Library->Appearance:Split Multi-Value Fields With

Needs a checkbox selection. Default should probably be ON to match 3.0 behavior.

Owyn

2008-12-15 03:11

updater   ~0015650

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35008
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35006

Mizery_Made

2008-12-15 23:32

updater   ~0015659

chrisjj has made a suggestion in regards to your minor tweak, Rusty. Suggesting it would read better for users if "This specifies what character is used to denote multiple values within a single field (e.g. Rock;Folk)" became "This specifies what character is used to separate multiple values within a single field (e.g. Rock;Folk)"

He might have a point, both read fine by I'm already familiar with what the option does, but "separate" might work better for a newer user who is not.

See: http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=35019

jiri

2009-02-20 14:22

administrator   ~0016801

Assigning to Rusty to review, but only after 3.1 release due to a string change.

rusty

2009-04-06 15:20

administrator   ~0017397

Setting to resolved since this has already been fixed. The only remaining item is context help which is being tracked with the todoc_context tag.

rusty

2009-04-08 02:01

administrator   ~0017462

Verified 1232.