View Issue Details

IDProjectCategoryView StatusLast Update
0004926MediaMonkey 4DB/FileMonitorpublic2008-11-20 22:18
Reporterrusty Assigned To 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Fixed in Version3.1 
Summary0004926: Database problems in 1192
DescriptionWith build 3.1.0.1192, upon first install, it updates the 3.0.6.1190 DB, then opens the tracklist with the library node in focus, but no tracks are shown. When the user clicks e.g. Artist node --> an AV occurs (report sent at 11:35pm), and the screen shows squares for most of the metadata.

When attempting to close MediaMonkey 3.1.0.1192 after the initial AV occurs, the UI closes, then a second AV occurs (report sent ~11:36pm), and MM fails to terminate.

If MM is then manually terminated via the task manager, then on restart, all fields display correctly!
Additional InformationPosting 3.0.6 db that exhibits this problem to the ftp server.
TagsNo tags attached.
Fixed in build1193

Activities

jiri

2008-11-13 10:20

administrator   ~0014929

Assigning to Petr to review the logs. It doesn't seem to be related to the alredy fixed DB issue (unless the DB was alredy corrupted somehow on Rusty's side, but I don't think so), it rather could be caused by the new TSongListData sharing?

petr

2008-11-13 13:38

developer   ~0014932

Fixed in 1193

rusty

2008-11-20 22:18

administrator   ~0015039

Verified 1193.