View Issue Details

IDProjectCategoryView StatusLast Update
0004872MediaMonkey 4Otherpublic2008-12-06 16:23
ReporterLudek Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Fixed in Version3.1 
Summary0004872: Don't show previously removed episodes in feed list
DescriptionThis was requested and would be nice to have in MM 3.1, see here:
http://www.mediamonkey.com/forum/viewtopic.php?t=28467

The user would like to have a mechanism to hide/remove episodes from the feed list.
TagsNo tags attached.
Fixed in build1198

Relationships

parent of 0005026 closedLudek Regression: Podcast: Newest episode incorrectly determined. 
related to 0005038 closedLudek Scanned tracks not shown for Dead Subscriptions 

Activities

Ludek

2008-10-09 13:34

developer   ~0014736

Last edited: 2008-10-09 13:37

So, I have made some changes in this area:

Generally I've added ability to remove and show already removed episodes in a feed.

1. If an episode is automatically deleted then its oposite on the internet (the greyed out episode) is no longer shown in the feed list until "Show Removed Episodes" entry is selected from the subscription menu.

2. If a user decided to remove some episodes and there is a downloaded episode in this set then the classical confirmation dialog is shown (whether he wish to delete also from the disk or only from library), but if there is no downloaded episode in the set (only the greyed out were selected) then there is the following confirmation:
'Are you sure that you want to remove X selected episodes from the feed? You will be able to see and download them later by selecting "Show Removed Episodes" from the feed menu.'
[[Ok]] [Cancel]

Rusty, please review the wording.

Added in build 1188.

rusty

2008-11-28 20:36

administrator   ~0015249

Tested 1196.

1)
a) Shouldn't 'Show removed episodes' be a toggle function (with a toggle indicator)?
b) 'Show removed episode links' should be added to the 'Edit subscription' dialog, since that's where users would expect to find it. It should be disabled by default.

2) Is a warning really required to delete pointers to episodes that don't even exist on the PC? If you think 'yes' I would just simplify this to:
'Are you sure that you want to remove the selected episode links? [[Yes]] [No]'

Ludek

2008-12-01 11:34

developer   ~0015269

You seem to be true,
1B) Added 'Show removed episode links' to the 'Edit subscription' dialog.
2B) The warning removed.

Fixed in build 1198.

stephen_platt

2008-12-06 16:23

developer   ~0015489

Verified 1201