View Issue Details

IDProjectCategoryView StatusLast Update
0004503MediaMonkey 4Playlist / Searchpublic2008-04-15 02:34
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Fixed in Version3.0 
Summary0004503: Search for exact word is no longer possible via search bar (if the word is not quoted)
DescriptionIn MM 2.5 if the user searched for ' fast' --> Breakfast wasn't returned.
In MM 3.0 ' fast' --> Breakfast is returned .
i.e. there's no way to restrict search to a whole word.

Setting to 'immediate' on the assumption that it's easy to fix, and because it's very annoying to some users.
TagsNo tags attached.
Fixed in build1159

Relationships

duplicate of 0003040 closedLudek Implement proper full-text search 
related to 0004566 closedLudek Regression: Trailing spaces are ignored in case of searching specified field and in Auto-Playlists 

Activities

Ludek

2008-03-28 23:50

developer   ~0013526

Last edited: 2008-03-28 23:54

Are you sure that this is not your test error?
Both "" and '' works fine for me in order to search the exact phrase.

i.e. Searching for ' fast' doesn't return breakfast, check whether the word 'fast' is not presented in another field.

rusty

2008-03-31 22:10

administrator   ~0013537

I just tested this out in 1149 and searching for "fast" returns "breakfast".

In fact, searching for "fast" yields the exact same results as searching for fast.

(note: tested on "entire library".

jiri

2008-04-01 11:30

administrator   ~0013542

I don't think that there's an easy and quick solution. I'd suggest to fully implement this in MM 3.1 using a real fulltext search, which will hopefully be possible using SQLite.

Ludek

2008-04-01 11:40

developer   ~0013543

Last edited: 2008-04-01 11:50

Ok, so you think that searching for "fast" should work like searching for " fast "? I didn't know that this was intended. You previously mentioned searching for ' fast' and this works fine, i.e. 'breakfast' is not returned.

Generally, I tend to Jiri.

rusty

2008-04-01 21:18

administrator   ~0013551

Closing as dup.

rusty

2008-04-11 19:49

administrator   ~0013712

Can this be fixed in the same manner as 0004566 ?

note that it is also a regression, and would meet most needs at least until we implement full text search.

Ludek

2008-04-11 20:15

developer   ~0013714

Rusty, I don't see any regression, keep in mind that in case of quick search the space has mean of AND operator, therefore you need to search for "[space] ape[space]" instead of single [space]ape[spece], i.e. it has to be quoted so that space is not recognized as AND operator.

Is that clear?

rusty

2008-04-13 12:33

administrator   ~0013716

Actually, I tested 2.5 and MM 3.x and the behavior is different. In 2.5 the users are able to find 'fast' but not 'breakfast' by searching for ' fast'. If it's not the same fix as you'd made for 4566 let me know... it just seemed like the same issue to me.

jiri

2008-04-13 23:00

administrator   ~0013717

I would suggest to not fix anything here until we implement a proper full-text search in MM.

Ludek

2008-04-14 09:43

developer   ~0013718

Last edited: 2008-04-14 09:47

Rusty as I wrote, searching for ' fast' works in MM3 too, but it needs to be quoted, I don't see any regression. Quick searching has been improved, because space is considered as AND operator and semicolon as OR operator.

Nevertheless I have done a little hack: if the first char of the search phrase is space then it is considered as space char and is added to the first search word despite the fact that the word is not quoted and if the last char of the search phrase is space char then it is considered as trailing space of the last word although it is not quoted. I think that this is a hack, but it satisfies your issue with minimal risk of regression.

Fixed in build 1159.

rusty

2008-04-15 02:34

administrator   ~0013739

Verified 1159.