View Issue Details

IDProjectCategoryView StatusLast Update
0004445MediaMonkey 4Now Playingpublic2008-08-27 14:07
ReporterLudek Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Summary0004445: Now Playing list is now stored to MediaMonkey.m3u only => this causes a problems
DescriptionPer discussion with jiri as a reaction on this bug:
0004443: Now Playing: Highlighted (last played) track's playcount is set to zero after MM restart

Problem is that in MediaMonkey.m3u are stored only paths to all tracks, but if we want to get info for a track from DB then we need to know its ID.
Now, it is solved by reading it from DB based on IDMedia+Path identification, but IDMedia is not known until UpdateDriveLetters thread has finished ->
i.e. We have to wait until this thread has finished in order to get full song info from DB.

Per discussion with Jiri a good solution would be to store also IDs of this tracks to a separate file (e.g. MediaMonkey.mmp) which would look like

ID: 123
ID: 125
...



TagsNo tags attached.
Fixed in build

Relationships

related to 0004443 closedLudek Now Playing: Highlighted (last played) track's playcount is set to zero after MM restart 

Activities

Ludek

2008-08-27 13:55

developer   ~0014494

Note: One of the reasons why we cannot have Now Playing list stored in DB is multi user enviroment. i.e. more users can share one DB.

As discussed by Jiri this is not at very high priority at this time.

jiri

2008-08-27 14:07

administrator   ~0014495

Closing the issue, currently the reasons for its implementation are no longer too important and also the suggested implementation wouldn't really work too well.