View Issue Details

IDProjectCategoryView StatusLast Update
0004147MediaMonkey 4Properties/Auto-Toolspublic2009-02-19 23:10
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Fixed in Version3.1 
Summary0004147: Unclear search mechanism for multiple-value tags: ';' can represent OR or AND
DescriptionCurrently searching for ArtistA;ArtistB returns tracks with Artist A OR Artist B. In contrast, in the Properties, ArtistA;ArtistB represents Artist A AND Artist B (in the default config).

This should be rationalized. In so doing, it should also be made possible to search for ';' e.g. search for :
Artist = ; --> all tracks that have ; separating artists
Artist = beatles; --> all tracks by the beatles that also have another artist (this is a little tricky though, since it might be Kinks;Beatles rather than Beatles;Kinks)
Artist= beatles;kinks --> all tracks that have both beatles and kinks (and possibly others) as artists

As far as searching for xORy, we'd need to replace the ';' with another character. I'm not sure what would make most sense. (perhaps it would makes sense to always use ; for OR and use + for AND).
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?t=20186
TagsNo tags attached.
Fixed in build1198

Relationships

related to 0003040 closedLudek Implement proper full-text search 
related to 0005104 closedLudek Search bar: Boolean 'OR' should be localizable 

Activities

rusty

2008-12-29 17:51

administrator   ~0015846

With the addition of full text search, this has been mostly resolved since:
-'OR' can now be used to search for A OR B
-';' can no longer be used in the search bar to mean 'OR'
-';' can be used in the search bar to search for multi-value attributes

The only function that's missing is the ability to search for 'U2;' to find all tracks containing 'U2;' or 'U2' plus some other value. However, I'm not sure that this is all that important.

stephen_platt

2009-02-19 23:10

developer   ~0016730

verified 1198