View Issue Details

IDProjectCategoryView StatusLast Update
0004078MediaMonkey (current)Properties/Auto-Toolspublic2016-11-23 16:01
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0004078: Year Tag isn't readable by Winamp
DescriptionIf user tags year info with MM, it is not readable in Winamp.

Reported and explained at:
http://www.mediamonkey.com/forum/viewtopic.php?t=23192
TagsNo tags attached.
Fixed in build1115

Relationships

related to 0004108 closedjiri Mass Edit: Disc# shows -1 for empty value 
related to 0013674 newrusty User should be able to determine read order when multiple tags can be read for one field value 

Activities

jiri

2007-12-05 11:35

administrator   ~0012295

Fixed in build 1113.
 - The whole thing was a little more complex, so I added a new feature. We should document it somewhere, preferably also in Wiki.

Here is my description from the forum:

--------
I have to disagree slightly here, the facts here are:

1. MM really writes TDRC frame in ID3v2.3 tag, which is only specified in ID3v2.4, but it also isn't directly against ID3v2.3 specification. The reasons for this were discussed in other threads here - we don't want to store ID3v2.4 (maybe in the future), but some 2.4 frames are useful.

2. The problem is mostly on the side of the other applications mentioned, e.g.:
- WinAmp: Yes, it doesn't show ID3v2 Year, but as I explained in 1., there's no real reason why it shouldn't do so. Also, some older versions, like WinAmp 2.2x _do_ show it properly in this case.
- Foobar shows date as '2001; 2001' even in case e.g. TDAT and TYER are present.

That said, we want to write tag according to our users needs and the best solution for now seems to be to make it a little configurable. So, the next release of MM will have two new MediaMonkey.ini file entries:

[MP3Tagging]
DisableFrames=TYER;TDRC
EnableFrames=TDAT

This way you can force MM to not write frames it normally writes (pretty much any frame can be disabled this way) and also force it to write frames it normally doesn't (applies only to TDAT frame at this moment).
-------

rusty

2007-12-07 19:35

administrator   ~0012358

I'm not sure I understand how this is supposed to work:

If I set:
[MP3Tagging]
DisableFrames=TYER;TDRC
EnableFrames=TDAT

Then neither MM nor Winamp can read the year if I save a year as eg. '1968'. Am I misunderstanding?

jiri

2007-12-07 20:04

administrator   ~0012365

Fixed in build 1115.

peke

2007-12-07 23:15

developer   ~0012366

Last edited: 2007-12-07 23:15

may I add one small sugestion that we change
[MP3Tagging] to [ID3v2Tagging] for more user friendliness
and possible usage in future version and additional customization.

jiri

2007-12-07 23:24

administrator   ~0012368

It makes some sense, but generally it isn't clear what exactly will be needed in the future (e.g. differences between ID3v2.3 and v2.4?) and so I'm leaving it as is.

peke

2007-12-08 13:23

developer   ~0012372

Basically I was thinking about to make it more global for all file formats that Uses ID3v2 Tagging and not just MP3s, but you are right it is still unclear what we can use it for exactly. For now it is better to leave as is.

rusty

2007-12-09 13:01

administrator   ~0012412

Verified 1115 (tested that tdat only; tyer only, are both readable in MM; and that TYER only is readable in Winamp).