View Issue Details

IDProjectCategoryView StatusLast Update
0003945MediaMonkey 4Burning / Disc Handlingpublic2008-09-03 11:51
Reporterjiri Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Product Version3.0 
Summary0003945: Faster data CD burning with auto-conversion
DescriptionCurrently whole auto-conversion is done before data CD burning starts. In order to make it faster, we should add an option to do these actions simultaneously.
TagsNo tags attached.
Fixed in build

Relationships

related to 0003946 closedLudek Use multi-kernel processor more efficiently 

Activities

jiri

2007-11-11 17:40

administrator   ~0011894

Assigning to Ludek as post 3.0 task.

Ludek

2008-09-02 21:28

developer   ~0014517

Last edited: 2008-09-03 11:48

I have been trying to implement this but there seems to be a serious technical problem that prevents us from implementing this.
In case of data DVD/CD burning there is a need to build image layout before the burning of individual files starts. I tried to create a dummy files ( with zero bytes lenght), but the layout creation fails. Another possibility is to use empty files for the layout creation and then fill them, but problem is that we cannot know the exact length of all the files until we convert them all.

In addition do this actions simultaneously would be very dangerous, in case the auto-conversion fails for a file then we cannot change the created CD image layout, because burning would proceed at the same time.

I guess that we should fix 0003946 that partially solves this issue too.