View Issue Details

IDProjectCategoryView StatusLast Update
0020639MMW 5Playlists (Auto) / Search / Filterspublic2024-05-27 00:18
Reporterzvezdan Assigned To 
PriorityhighSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version5.1 
Target Version5.1Fixed in Version5.1 
Summary0020639: Changing criteria in auto-playlists doesn't update tracklist always
DescriptionIf I change some existing criterion on the auto-playlist editor, the status bar will show the correct info in the status bar, but the tracklist could be empty. I need to press F5 to fill it.
TagsNo tags attached.
Fixed in build3022

Relationships

related to 0020937 closedLudek Editing autoplaylist criteria sometimes fails (aka clicking outside an open combo box causes another combobox to open) 

Activities

Ludek

2024-04-24 18:35

developer   ~0075237

I can't replicate, are there any specific steps?
Is it specific to certain criteria?
Could you please catch it in screencas video?

zvezdan

2024-04-24 23:34

updater   ~0075261

Last edited: 2024-04-24 23:50

Well, I can't replicate it either, that is why I marked it as random reproducibility. If you responded sooner after I reported it, maybe I would remember how to reproduce it.

However, I can reproduce several other anomalies with the auto-playlist editor. The first one is similar to the reported issue, but with the opposite behavior:
- choose a field having files with the criterion Is Known, in my case Last Played Is Known;
- choose another field that don't have any file with the criterion Is Known, in my case it is Last Skipper Is Known -> the tracklist displays the first file from the previous match, status bar displays nothing.

The second issue, the dropdown list stays open and moved to the left side of window, in my case it is the list of extensions, but many others have the same behavior, e.g. Media, Producer, Tempo, Quality...

The third issue is similar to the previous, the dropdown list stays open, but it is not moved immediately to the left side of window.

The fourth issue is quite specific, it is manifesting with Episode #, but I don't have any file with that tag:
- Title starts with A -> there are many files;
- choose Episode #, choose Is Known -> the tracklist displays the same files as before, the status bar is not changed either;
- choose another field that don't have any file, in my case Album Comment -> the tracklist displays the first file from the previous match, status bar displays nothing, similarly to the first issue;
- choose again Episode # -> the tracklist is now empty as it should be.

Update: the fourth issue is manifesting also with Disc# and Season # in my case since I don't have any file with them.

Ludek

2024-05-23 15:41

developer   ~0075488

Fixed in 3022

peke

2024-05-27 00:18

developer   ~0075555

Verified 3024