View Issue Details

IDProjectCategoryView StatusLast Update
0019603MediaMonkey for AndroidPlaybackpublic2022-12-21 03:54
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version2.0.0 
Target Version2.0.0Fixed in Version2.0.0 
Summary0019603: Playing MM causes Ring and Notification volume to be set to 0
DescriptionInitiating playback in the newest build (on Android 13) always causes Ring and Notification volume to reset to 0!
TagsNo tags attached.
Fixed in build1055

Activities

martin

2022-12-05 22:20

developer   ~0070499

I cannot replicate on my Android 13 device. Please send your logs to check your settings.
Don't you have enabled "Suppress notification sounds"?

rusty

2022-12-06 22:29

administrator   ~0070502

Last edited: 2022-12-06 22:54

Yes, 'Suppress notification sounds' was enabled. But it seems that somewhere along the way this functionality has changed or is documented incorrectly (the functionality description is 'Suppress changes in volume triggered by notifications' which implies that the _notifications still come through_, but without affecting Playback volume. AFAIK this was how this worked in earlier iterations of MMA).

Before deciding on the text, we need to agree on what the functionality is supposed to be. On testing, it seems that when this option is disabled, any incoming notification causes MM's playback volume to change. Considering that Media Volume and Notification Volume are configured independently in recent versions of Android, isn't this a bug? Why should notifications (which are controlled by notification volume) ever affect playback (which is controlled by Media volume? I tested with youtube and incoming notifications don't affect playback volume.

If we agree that functionality should be as proposed above, then the wording should be changed to:
Disable notification sounds
Disables notification sounds while playing.

If, for some reason, MMA volume cannot be independent of notification volume, then the wording can be:
Disable notification sounds
Disables notification sounds while playing (prevents volume changes)

martin

2022-12-09 16:38

developer   ~0070509

'Suppress notification sounds' functionality is divided into two options.
1) 'Suppress notification sounds',
 <Suppress changes in volume triggered by notifications>
When it's enabled, notifications do not reduce the playback volume. Also, I have added detection and when the notification sound is set to "silent" or "vibrate", the playback volume is not reduced regardless of the setting of this option.
2) Disable notification sounds
<Disables notification sounds while playing. >
This functionality has been there since the beginning i.e. mute notification sounds during playback.
A user can substitute this functionality by switching the notification mode to "silent" or "vibrate". So the question is how much this functionality is in demand.

Fixed in build 2.0.0.1051

martin

2022-12-12 07:14

developer   ~0070518

The option is divided in next build 2.0.0.1051

rusty

2022-12-13 03:25

administrator   ~0070526

Tested 1051 on Android 13, and this is what the functions actually does (and how it should probably be described):

1) Prevent notifications from changing volume
<Prevents notifications from changing volume while playing.>

2) Disable notification sounds
<Disables notification sounds while playing. >

OR alternatively
Notification handling during playback
Prevent volume changes [ ]
Disable notification sounds [ ]

martin

2022-12-13 14:33

developer   ~0070537

Fixed in build 2.0.0.1052

rusty

2022-12-14 03:00

administrator   ~0070550

Tested 1052 and the following is truncated, so perhaps it should be changed as follows:
Prevent notifications from changing volume
-->
Prevent notification volume-changes

martin

2022-12-14 15:51

developer   ~0070556

Fixed in build 2.0.0.1053

rusty

2022-12-16 04:22

administrator   ~0070598

This is still too wide. How restructuring slightly as follows (all descriptions should be retained--they're just not shown below):

-Audio-
Level volume
.....
Audio transitions: Gapless
.....

-Notification & System sounds-
Prevent volume changes
....
Disable notification sounds
....
Disable touch sounds
....

2) Also, minor tweak to the 'Level Volume' description:
Adjusts the volume level for tracks with volume information.
-->
Adjusts volume for tracks with volume information.

martin

2022-12-16 12:42

developer   ~0070600

Fixed in build 2.0.0.1054

rusty

2022-12-16 16:30

administrator   ~0070603

1054 looks good.

One minor point. I think you forgot to change:

Prevent notification volume-changes.
-->
Prevent volume changes.

Or was that intentional?

martin

2022-12-19 20:00

developer   ~0070629

Fixed in build 2.0.0.1055

rusty

2022-12-21 03:54

administrator   ~0070674

Verified 1055.