View Issue Details

IDProjectCategoryView StatusLast Update
0019573MediaMonkey 5Playlists (Auto) / Search / Filterspublic2022-11-21 18:27
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019573: Contextual search causes tree navigation to open wrong node (regression)
DescriptionWhen a contextual search is performed on a particular node, if the user switches to another node then either of the following can occur:
A) MM will revert back to the original node
B) MM will display the new node but any contextual searches will be performed on the old node

I haven't been able to determine why A) vs B) occurs, but it can be replicated as follows:
A)
1 Click Genre 1 in the tree
2 Type a couple of letters to filter the node (pressing ENTER seems to help trigger the issue more often, but isn't required)
--> Filter results display
3 Click Genre 2 in the tree
--> Genre 2 is shown in the breadcrumb bar, but Genre 1 contents are displayed!

B)
1 Click AutoPlaylist1 in the tree
2 Type a couple of letters to filter the node (pressing ENTER seems to help trigger the issue more often, but isn't required)
--> Filter results display
3 Click Music > All tracks
--> All tracks appears to display
4 Type a couple of letters to filter the node
--> The filter results from step 2 appear!

Note that in case B) the contents of the second node actually display, but the filter applies to the content of the first node. It occurs much more rarely (and I wonder whether it's actually just an example of case A) and that the tester simply didn't notice that the wrong node's contents were displayed at step 3) ).

p.s.
- I've replicated the issue in both List and List (by Album) views.
- It doesn't occur in 5.0.3
https://www.screencast.com/t/M9wAJCGAB
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?t=102965
Ticket # 5062
TagsNo tags attached.
Fixed in build2690

Relationships

related to 0019259 closedLudek Clicking cancel in the inline search it should return to previous view 

Activities

Ludek

2022-11-18 23:53

developer   ~0070399

Fixed in 2690

peke

2022-11-19 00:11

developer   ~0070403

Last edited: 2022-11-19 00:12

Test note 26889 B): If you double click (or do second click to confirm selection) on All tracks in step 3 it shows normally.

I can't replicate A) behavior.

Ludek

2022-11-19 16:45

developer   ~0070404

Ok, so ask anyone else to verify.

For me it was easy to replicate and the fix in 2690 is very safe (not a risk for a regression)

rusty

2022-11-21 18:18

administrator   ~0070414

Verified 2690.

lowlander

2022-11-21 18:22

developer   ~0070415

I'm unable to reproduce either on 2690 (but never have been able to reproduce B when testing user report).

peke

2022-11-21 18:27

developer   ~0070416

Confirming B) is fixed in 2690 I never been able to replicate A) thx @lowlander