View Issue Details

IDProjectCategoryView StatusLast Update
0019559MediaMonkey 5Generalpublic2022-11-21 19:55
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.1 
Summary0019559: Crash A35A0000 after testing auto-tagging (Disk I/O error)
DescriptionAfter testing 0019543 and then leaving my desk (with Music > Location > NetworkPath open), upon returning 5 minutes later, MM had crashed (crashlog A35A0000) and none of the tracks from the network path were shown.

My suspicion is that there was a transient network issue and MM didn't accept it gracefully. Another possibility is that it's somehow related to the fact that much of the content on the local drive was inaccessible due to a modified drive serial.

Hopefully the log can confirm.
TagsNo tags attached.
Fixed in build

Relationships

related to 0019578 feedbackrusty Improve error handling when DB cannot be accessed 

Activities

Ludek

2022-11-15 12:43

developer   ~0070310

Last edited: 2022-11-15 12:51

In the crash log I see:
"Could not retrieve data "SELECT Songs.Id AS SongID FROM Songs WHERE (Songs.TrackType in (3)) LIMIT 1" : disk I/O error (10, 10)."

Couldn't the "Disk I/O error (10, 10)" be caused by disabling BitLocker while still working on that maching? The rationale is that you asked me yeaterday how long it takes to disable BitLocker on Win11?

Further possible reasons for Disk I/O error 10 is e.g. full harddrive, more at https://www.redcort.com/timeclock/support/blog/error-10-disk-io-error

Anyhow this isn't something that can be fixable within MM5, the only we could do is to show such an error as dialog window (rather than generating crash log).

rusty

2022-11-15 13:55

administrator   ~0070313

I should have mentioned: MM crashed, but also froze and had to be force-closed. I would have expected that MM would generate an error and not freeze.

p.s. MM and most of the music were running/stored on a portable drive at the time (i.e. it's unrelated to bitlocker), but much of the music in the library was inaccessible because the drive's serial ID hadn't been updated (in Locations, it appeared as drive name [Data]).

Ludek

2022-11-15 20:48

developer   ~0070322

Last edited: 2022-11-15 20:52

Re: "MM crashed, but also froze and had to be force-closed"
OK, this could have been caused be the inability to read/write from the disk.

Do you suggest to show rather an error dialog box once the " disk I/O error (10, 10)" error is detected?
Any wording suggestions?

Changed target to 5.1 as it requires new strings and the appearance of "disk I/O error (10, 10)" error is quite rare in crash logs (e.g. once per month).

rusty

2022-11-15 21:42

administrator   ~0070327

How about:
Error reading file (can 'Error while reading file info', an existing string, be modified and used for both cases?)
Error code: <error code returned by windows>

Ludek

2022-11-21 19:55

developer   ~0070417

Moving to 0019578