View Issue Details

IDProjectCategoryView StatusLast Update
0019393MediaMonkey 5Playlists (Auto) / Search / Filterspublic2022-10-04 21:24
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019393: Filters are not restored correctly when MM is closed on the second tab
DescriptionNormally, if there are 2 tabs 'Playing' & 'Music > ... [Filter]', switching back and forth between the tabs doesn't cause the filter to appear in the Playing tab. But in the following case, it does:

1 Enable 'Playing' & 'Music > ... [Filter]' tabs
2 Switch to the 'Music > ... [Filter]' tab
3 Restart MM
4 Switch back to the 'Playing' tab
--> The breadcrumb shows 'Playing [Filter]'

Note: the filter just _appears_ to be active--it isn't actually applied to 'Playing'. Also, closing the filter in the Now Playing tab doesn't disable the filter (it continues to work properly in other tabs).
TagsNo tags attached.
Fixed in build2668

Relationships

related to 0018257 feedbackLudek Filters persist when changing nodes 

Activities

rusty

2022-09-29 14:18

administrator   ~0069569

This issue is more severe than originally thought (raised to Urgent for 5.0.4) since the issue is more generalized than originally reported. i.e. restarting MM always:
a) Causes filtered tabs to appear with an empty filter that cannot be deleted
b) Transfers an empty filter to tabs that previously weren't filtered

e.g.
1 Run MM and open 2 tabs:
 . . - Music > Genres > Acoustic Rock > Filter (ratings>3stars) [Browser]
 . . - Music > Location > Path [List (by Album)]
2 With focus on the second tab, close MM and restart
--> A blank filter icon appears on both tabs and cannot be deleted i.e. breadcrumbs display as follows with an empty filter!
Music > Genres > Acoustic Rock > [Close Filter icon]
Music > Location > Path > [Close Filter icon] [List (by Album)]
3 Try to close the filter
--> Nothing happens!

The only way to get rid of these 'empty filters' is to either:
a) edit the filter and assigning a query to it, and then deleting it.
b) restart MM a second time

Ludek

2022-10-03 16:37

developer   ~0069625

I can confirm the bug and the bug exists even in 5.0.3 -- the key to replicate is to have at least two tabs opened and close MM on the _second_ tab.
Closing MM on the first tab does not result in the issue.

Ludek

2022-10-03 20:19

developer   ~0069627

Fixed in 2668

lowlander

2022-10-04 21:24

developer   ~0069648

Verified on 2668. Tab 1 retained filter and Tab 2 didn't have any filter associated exactly as it was pre-restart.