View Issue Details

IDProjectCategoryView StatusLast Update
0019380MediaMonkey 5UPnP / DLNApublic2022-10-12 17:05
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019380: UPnP playback of certain track formats --> failure and/or crash C33DC74A
DescriptionInitiate playback over UPnP by double-clicking 'Baby you're a rich man' from within Folders > NAS2 (Media Server) > Music > Genre > Pop
--> playback fails (not sure why--its an .m4a track playable in MM5 over the network)
---> MM switches to Back in the u.s.s.r -- playback fails (not sure why--its an .m4a track playable in MM5 over the network)
---> MM switches to Bad Romance -- playback fails (not sure why--its an .m4a track playable in MM5 over the network)
---> MMW switches to Bad Timing -- playback fails (not sure why--its an .ogg track playable in MM5 over the network)
---> MMW doesn't advance to any more tracks
Line 19000 Pressed STOP --> No effect
Line 21500 Attempted to Close MM
--> Crash C33DC74A
Press 'Continue'
--> MM remains frozen

Note:
- this bug is consistently replicable
- content is being served by a MediaServer running on a QNAP server
- codec pack 3.0.7 is installed
- when I try to initiate playback of the .ogg track, the bug also occurs--getting stuck on that track
- when I try to initiate playback of an .mp3 track, the bug doesn't occur
TagsNo tags attached.
Fixed in build2667

Relationships

related to 0019384 closedmichal Playback over the network: missing tracks stop playback (regression) 
related to 0018764 newmichal Some specific streams (chunked wav) being transcoded from an older QNAP are not playable in MM 
related to 0018398 closedLudek Playback of wav files over UPnP --> crash C33D3070 / C33D6716 
related to 0019408 assignedmichal UPnP/Streaming: improved handling of non-seekable streams 
related to 0019409 assignedmichal UPnP/Streaming: handling of wav streams 

Activities

Ludek

2022-09-19 14:46

developer   ~0069364

Last edited: 2022-09-19 15:20

Based on the log this looks like duplicate of 0018398:0065051 that is now tracked as 0018764

i.e. this is again issue playing chunked streams transcoded to WAV , like:
http://192.168.0.147:8200/Transcode/A0$128$132$590083$392626436.wav?type=1,sfid=5,said=86021,sach=2,findex=0,vindex=-1,aindex=256,enMux=2,duration=309,client=25,mime=audio/wav,pn=LPCM,ext=.wav

i.e. the issue that I could not replicte previously even with the Rusty's VPN as for some reason it did not transcode , deatils in 0018398:0065051

i.e. in_mfaudio.dll tries to play the stream like
 http://192.168.0.147:8200/Transcode/A0$128$132$590083$726466820.aac?type=1,sfid=65544,said=86018,sach=2,findex=256,vindex=-1,aindex=10,enMux=16,duration=163,client=25,mime=audio/vnd.dlna.adts,pn=,ext=.aac
but gets probably incorrect data, i.e. WAV instead of AAC or vice versa..

At least this was the case in 0018764 previously

EDIT:
Another idea I have just got is the possibility that both transcoded and non-transcoded links are served, but MM selected the incorrect one.
To ensure whather this is the case I would need to add some debug message to UPnP.dll

So please download this UPnP.dll https://www.dropbox.com/s/o7wdur1c5nyglyh/UPnP.dll?dl=0
and re-generate the log for me.

Thx.

Ludek

2022-09-20 15:21

developer   ~0069403

Last edited: 2022-09-20 15:23

From the log I ensured that there isn't another UPnP/DLNA resource for the problematic track(s) and thus in_mfaudio.dll tried to play the served resource:

http://192.168.0.147:8200/Transcode/A0$128$132$590083$727777540.aac?type=1,sfid=65544,said=86018,sach=2,findex=256,vindex=-1,aindex=10,enMux=16,duration=183,client=25,mime=audio/vnd.dlna.adts,pn=,ext=.aac

BUT I see that on the URL above:
1) the HTTP range requests are not allowed
2) It's MIME type is 'audio/vnd.dlna.adts'

So it looks like in_mfaudio.dll has trouble playing 'audio/vnd.dlna.adts' mime and another plugin should be used for playback of such a streams??

Rusty, please set up VPN for Michal to test and then assign to Michal for analyzing the stream playback issue.

BTW: The crash is the "Not all close events finished" assertion which means that the playback task has been frozen in the in_mfaudio.dll and couldn't be terminated.

rusty

2022-09-22 16:27

administrator   ~0069485

Last edited: 2022-09-23 15:52

fyi, with build 2664, playback of Folders > NAS2 (Media Server) > Music > Genre > Pop, starting with 'Baby you're a rich man'
--> playback never starts. The first track 'Baby you're a rich man' just stays highlighted.
If I try to close MM, it closes successfully.

[EDIT]
This occurs for each of the subsequent tracks (Back in the USSR, Bad Romance) although occasionally a track will skip to the next one rather than stopping immediately.
HOWEVER, when I double-click the Bad Timing track, MM freezes and generates crashlog C33DC74A

Note: when I try to play each of the first 3 tracks (Baby you're a rich man, Back in the USSR, Bad Timing) the track in Bubble UPnP it results in No compatible decoder found. Bad Timing plays successfully though.

Summary [EDITED]:
It seems that there are 2 issues with MM5:
1) It doesn't automatically advance to the next track in cases when the track can't be decoded
2) It crashes on the Bad Timing file (it's an .ogg file, but it's listed as a .wav file when accessed over UPnP)

michal

2022-09-27 11:52

developer   ~0069534

Fixed in build 2666. The main problem was inside MediaFoundation framework (in_mfaudio), is does not return sample in some specific situations and does not indicate any error or anything. I have tried to make workaround and it seems to work for me. Please test playback of network files and live streams more, as the changes were quite risky (but necessary, as it could cause crashes for users).

rusty

2022-09-28 16:46

administrator   ~0069548

Tested build 2666 and it seems to fail in the same manner as previous builds:
. . . Clicked Baby You're a rich man --> fails to play and doesn't advance
16640 Double-clicked Back in the USSR --> fail to play and doesn't advance
17991 Double-click Bad Romance --> Plays successfully
19224 Double-click Bad Timing --> Fails to play and then advances to the next track 'Be OK' after several minutes
27300 Double-click Bad Timing and attempt to close MM instead of waiting several minutes
--> Crash C33D37BF
MM must be force terminated (which I did after several minutes at line 33809)

rusty

2022-09-28 17:29

administrator   ~0069550

On a clean install without the codec pack, playback of 'Bad Timing' and then attempting to close MM results in crash C33D74A1

michal

2022-09-28 19:35

developer   ~0069555

Last edited: 2022-09-28 19:35

Problem with "Baby You're a rich man" and related fixed in build 2667.
Bad Timing is different issue - it is related to playback of WAV online, with seek (http range requests) disabled.

michal

2022-09-29 13:36

developer   ~0069568

Fixed in build 2667. Live stream of WAV files is skipped now, instead of crash.

rusty

2022-09-30 19:08

administrator   ~0069588

Verified issues 1) (tracks play successfully now) and 2) (problematic tracks are skipped instead of MM getting 'stuck'/crashing). Remaining issues are tracked at 0019408 / 0019409 .

Leaving as 'Resolved' for Peke to test for regressions re. network / streaming / upnp playback.

peke

2022-10-12 17:05

developer   ~0069767

Verified 2670

No crashes happen TS streams are skipped.