View Issue Details

IDProjectCategoryView StatusLast Update
0019316MediaMonkey for AndroidSynchronizationpublic2022-08-26 21:01
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.0.0Fixed in Version2.0.0 
Summary0019316: Wi-Fi Sync operations are re-triggered and queued by navigating to the sync view
Description1 When I initiate a sync operation
--> I'm prompted whether to delete/update sets of tracks
2 Choose the 'Garbage can' and click the checkmark
--> Deletion proceeds, and then tracks start downloading
3 After all tracks have downloaded
--> A dialog appears indicating analysis is underway
--> I'm again prompted whether to delete/update sets of tracks
4 Press cancel or the checkbox
---> Tracks don't delete or delete and then downloads proceed again!
--> When all downloads have completed, the UI returns to step 3!
5 Navigate to the Sync Status dialog and press Cancel
--> A new sync operation initiates!

Note: it's impossible to Terminate MM5 or MMA at this stage:
- MMA keeps initiating sync operations!
- MM5 keeps giving warnings about background processes running even after choosing to stop the processes!

I'm not sure if this is a regression OR if it's related to the fact that between steps 2 and 3 I navigated to the MMA home screen and then:
- On one occasion, clicked the 'Sync' button in order to navigate back to the sync status dialog
- On another occasion, clicked the sync notification dialog in order to navigate back to the sync status dialog
My suspicion is that the above actions may somehow add a second sync operation to the queue and that it begins before the first operation is complete. Testing further...

 
TagsNo tags attached.
Fixed in build1024

Relationships

related to 0019331 closedmartin MMA Wi-Fi sync regularly disconnects 

Activities

rusty

2022-08-23 21:38

administrator   ~0069050

Last edited: 2022-08-23 21:59

Initiated a sync. Sync is configured to sync a number of dynamic autoplaylists

????? Selected tracks in MMA to be updated and deleted
14370 Tracks being deleted (281 tracks)
17000 Analyzing
23000 Downloading (635 tracks)in MMA. Note that the number of tracks is surprising--I would have expected about 281 tracks to download.
36860 MMA shows Sync status page, in which the last entry is 'Server not responding'

Submitted MMA log PXYWEU7J2V (just in case it's useful)

36959 Initiate another Wi-Fi sync
40155 Confirm 167 Tracks to be deleted
--> Tracks being deleted
40180 Analyzing
48000 Downloading (613 tracks)
63020 MMA shows Sync status page, in which the last entry is 'Server not responding'

63085 Initiate another Wi-Fi sync
66051 Confirm 111 tracks to be deleted
--> Tracks being deleted
In MMA go 'Back' to the Music node, and then to the 'Home' node
In MMA expand the progress indicator in the Home node and verify that tracks are being downloaded (they are).
In the Notifications drawer, open the 'Synchronization' notification to get back to MMA's synchronization page
80000 Tracks still downloading (32/698)
106671 MMA displays the confirmation dialog, prompting deletion of 79 tracks!

My guess as to what happened is that there was a sync error (exactly as in the first 2 cases), but the sync status dialog was skipped (when I initially replicated the problem last week, the sync status dialogs usually displayed). Then, because I had navigating back to the Synchronization node from the Home node (either by clicking the Synchronization notification OR by clicking 'Sync now' during the synch operation) MM queued another Sync operation that started immediately as soon as the first sync operation completed.

141084 Sync status dialog displayed due 'Server not responding error' (submitted MMA log 8Y2SJXZYCE)
141171 Attempted to close MM and MM closed successfully


Summary: this issue consists of 3 separate bugs
1) Wi-Fi Sync operations are being terminated prematurely when MMA 2.0.0.1023 is used with MMW 5.0.4.2660 (this should be tracked elsewhere, if it is in fact a bug--Ludek should analyze the MMW logs saved to ftp).
2) If the user switches (in MMA) to the Sync dialog from another dialog (by tapping the Sync notification OR by clicking 'Sync now'), then MMA queues a second sync operation. It should instead just switch to the sync view. This is tracked here in 0019316
3) When multiple sync operations get queued in this manner, MMW sometimes fails to terminate (Tracked at 0019323).

rusty

2022-08-24 15:02

administrator   ~0069055

Last edited: 2022-08-26 14:01

Re. issue 1), I retested with MMW 5.0.4.2657 and the issue still occurs so it's likely either an MMA issue or related to the network environment. I couldn't test MMA build 1020 with the current settings since Android doesn't allow me to 'update' to an earlier build--it generates an error 'App not installed as package appears to be invalid'. Nonetheless, I suspect that this is related to MMA since this type of bug has never occurred previously.

EDIT: tracking this at 0019331

martin

2022-08-25 16:33

developer   ~0069060

Fixed in build 2.0.0.1024

rusty

2022-08-26 21:01

administrator   ~0069068

Verified issue 2 (repeated sync operations after exiting and re-entering sync status page) in 1024. Issues 1 and 3 are tracked elsewhere.