View Issue Details

IDProjectCategoryView StatusLast Update
0019264MediaMonkey 5Casting (Google Cast / UPnP)public2022-11-17 13:46
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019264: Casting to some players (like OPPO UDP-20) can result in skipping some tracks
DescriptionUser from ticket # 4505 reports track skipping with additional logs/info.

- all tracks play fine when selected individually on mm5 to the oppo 205.
- all tracks play fine using the mm app for samsung s7 android phone to control playback to the oppo 205.
- all tracks play fine using mm4 on a sony vaio with windows 10 to the oppo 205.
- but mm5 is basically skipping every other song in every playlist to the oppo 205
TagsNo tags attached.
Fixed in build2687

Relationships

related to 0017074 closedLudek Player Seekbar jumps when playing to UPnP client 
related to 0016595 closedLudek Issues when playing to Raspberry DLNA client 
related to 0018152 closedLudek Bose Soundbar 700 does not postpone to the next track when casting 

Activities

Ludek

2022-07-19 12:38

developer   ~0068858

Last edited: 2022-07-19 12:46

Based on code analyzing looks like a regression introduced while fixing 0017074

But seems specific to the Oppo 205 that erroneously sends position info response of previous track (during first seconds of playback of the next track).

Ludek

2022-07-19 13:17

developer   ~0068859

Fixed in 5.0.4.2658

Ludek

2022-08-31 20:17

developer   ~0069131

Re-opened, there is still an issue with OPPO based on the most recent logs attached to the ticket 4505

Ludek

2022-10-10 10:12

developer   ~0069739

Last edited: 2022-10-11 17:22

It was definetly resolved in 2670 and confirmed by user Bob from ticket # 4505

Ludek

2022-10-10 16:23

developer   ~0069749

Last edited: 2022-10-10 16:41

While the change fixed the issue for Bob's OPPO player in 2670 it caused a regression for Carsten's player ( ticket # 4890 )

=> Fixed in 2671

Ludek

2022-11-17 13:42

developer   ~0070365

Re-opened: One of the tweaks in 2671 caused that Denon players now exhibits the same issue like Bose Soundbar in 0018152

Details in ticket # 5050

=> Fixed in 2687