View Issue Details

IDProjectCategoryView StatusLast Update
0019249MediaMonkey 5Tagging / organizing (properties / auto-tools)public2022-10-04 21:09
Reportermichal Assigned To 
PriorityimmediateSeverityminorReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019249: Artwork search does not return results.
DescriptionIt seems, our image searching stopped working. But it seems only for some users.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=499059#p499059
TagsNo tags attached.
Fixed in build2668

Relationships

related to 0018824 closedmichal MediaMonkey 5 Artwork lookup fails 
related to 0019216 newpetr MediaMonkey 5 Chromium update to v102/v103 
related to 0018827 closedmartin MediaMonkey for Android Album Art lookup isn't working 
related to 0019418 closedmichal MediaMonkey 5 Artwork lookup fails 

Activities

peke

2022-07-10 20:57

developer   ~0068798

As pointed not happening to everyone.

Searched 2k album arts not a single no result page.
image.png (70,786 bytes)   
image.png (70,786 bytes)   

petr

2022-08-15 16:35

developer   ~0069009

Crash is fixed so you can make confirmation window visible.

petr

2022-08-17 18:18

developer   ~0069013

Crash fixed

michal

2022-08-18 12:29

developer   ~0069014

Fixed in build 2660. We now display window with Google page for accepting/refusing Google cookies, if needed. It seems to be the only way to make Google search working again.

lowlander

2022-08-18 18:34

developer   ~0069018

Can't comment on cookies as I've never encountered it, but Artwork search works much more reliably than 2659 for me.

peke

2022-08-19 21:20

developer   ~0069032

Verified 2660

THX @Michal for pointing out how to trigger cookie.

TEST NOTE: I needed to use VPN to Germany to be able to trigger it once and after retest I was unable to trigger again.

michal

2022-08-22 18:15

developer   ~0069045

It is probably really only in some countries, probably only EU.
Reopening, we will need some dialog, which would explain to user in advance, what to do with the window. I.e. something like "To allow image searching, please Accept or Reject cookies in the next window, then close it." Currently it is not clear, why the window with page "Before you continue to Google" is displayed.
Rusty, could you specify correct wording? It will be new string to translate, but we do not have anything usable yet.

michal

2022-08-29 16:02

developer   ~0069087

Improved in build 2662. Used notification in toast message and automatic closing after pressing reject/accept in the Google page.

peke

2022-09-09 21:55

developer   ~0069199

Verified 2662

All working for me, no regressions found.

michal

2022-10-02 11:50

developer   ~0069610

Fixed in build 2668.

lowlander

2022-10-04 21:09

developer   ~0069646

Verified on 2558.