View Issue Details

IDProjectCategoryView StatusLast Update
0019205MediaMonkey for AndroidNavigationpublic2022-09-30 20:16
Reporterrusty Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.0.0Fixed in Version2.0.0 
Summary0019205: Improved Default Navigation hierarchy/order (consistent with MM5)
DescriptionThe default navigation settings can be tweaked as follows:

1) Home screen:
Albums, Artists & Album, Genres, Classical music, Podcasts, Audiobooks, Video, Media servers, Playlists, Folders, Now Playing
-->
Albums, Artists (=Artist&Album Artists see 0019161), Genres, Classical music, Podcasts, Audiobooks, Video, Playlists, Folders, Media servers, Now Playing

This is just to make it consistent with MM5 both in terms of order and terminology.

2) Music: Default Tab navigation order should match MM

Location, Tracks, Albums, Artists (=Artists&Album Artists), Composers, Genres, Years, Ratings

-->

Tracks, Albums, Genres, Artists, Composers, Years, Ratings, Location

3) Years: like in MM5, allow the user to browse by decade rather than year

And within each decade, allow the user to view by Artists, Albums, or Tracks (like with Genres)

4) Ratings:

Within each rating category, allow the user to browse by Artists, Albums, or Tracks (like with Genres)
TagsNo tags attached.
Fixed in build1021

Relationships

related to 0019254 newmartin Years: like in MM5, allow the user to browse by decade rather than year 
related to 0019255 newmartin Ratings - allow the user to browse by Artists, Albums, or Tracks 
related to 0019161 closedmartin Artists / Album Artists terminology should be the same in MMW and MMA 
related to 0019046 resolvedrusty Classical music: TAB Navigation should be modified according to needs 
related to 0019047 resolvedrusty Tab Navigation: Improve customization 

Activities

martin

2022-07-14 12:51

developer   ~0068823

1) fixed according to MM5 (except Genres must be before artist to be consistent with Music subnodes)
2) Fixed
3) Created 0019254 with target 2.0.1 because it's a new feature
4) Created 0019255 with target 2.0.1 because it's a new feature

1) and 2) fixed in build 2.0.0.1021

peke

2022-09-30 20:16

developer   ~0069598

Verified 1,2 in 1027