View Issue Details

IDProjectCategoryView StatusLast Update
0019091MediaMonkey 5Extensions frameworkpublic2022-05-25 19:57
Reporterzvezdan Assigned To 
PriorityhighSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version5.0.3 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019091: getFileInfoAsync doesn't return the same Date Mod/Cre/Acc values as Windows Explorer
DescriptionFiles have 1 hour difference. Folders has mostly the same values for Date Modified/Created/Accessed as in Windows Explorer/Total Commander, but not always.
TagsNo tags attached.
Fixed in build2650

Relationships

related to 0019095 resolvedLudek Methods to get/set the read-only file/folder attribute is needed 

Activities

Ludek

2022-05-24 20:21

developer   ~0068223

Probably UTC versus local time issue? To be confirmed...

Ludek

2022-05-25 12:44

developer   ~0068231

Last edited: 2022-05-25 12:45

View 2 revisions

I am unable to replicate, it is showing local time both in Windows Explorer and via the getFileInfoAsync, wondering what could be the difference? Is this occuring for all files (or e.g. only for a half year old files or so) ?
image.png (50,438 bytes)   
image.png (50,438 bytes)   

Ludek

2022-05-25 12:49

developer   ~0068232

Also for 6 years old files it is showing the same values, what's your time zone? Mine is GMT +2
image-2.png (26,012 bytes)   
image-2.png (26,012 bytes)   

zvezdan

2022-05-25 13:18

updater   ~0068233

I cannot reproduce it. Maybe it has something with my actions in the program that preceded that testing. I will report if I detect it again.

However, one here is something that is reproducible and could be seen on screenshot. The Date accessed always reports the time when the command is executed, while the Windows shows it differently, even after several opening/closing the Properties dialog.
screenshot.10.png (38,217 bytes)   
screenshot.10.png (38,217 bytes)   

zvezdan

2022-05-25 14:51

updater   ~0068235

Here is the screenshot with one hour difference in Date Modified. You could see what commands preceded it in the DevTools, but I will try to see if it is reproducible. I think it has something with overwriting the existent file.
screenshot.11.png (45,603 bytes)   
screenshot.11.png (45,603 bytes)   

zvezdan

2022-05-25 15:25

updater   ~0068237

Here is another one. I got it after copying file from one folder to another by Total Commander, i.e. it is not related to MM commands.

All tested partitions are NTFS.
screenshot.13.png (25,865 bytes)   
screenshot.13.png (25,865 bytes)   

zvezdan

2022-05-25 15:50

updater   ~0068240

Well, it doesn't depend on partition type, since I got the same difference with FAT32. And it has nothing with copying, since I got the same difference with files that already existed in different folders on different drives. But is is random, and I cannot find any relation between them.

zvezdan

2022-05-25 15:58

updater   ~0068241

It is not random. It is related to the daylight saving correction. You should check files with the Date Modified during winter.

Ludek

2022-05-25 17:21

developer   ~0068247

Last edited: 2022-05-25 17:25

View 4 revisions

OK, I can confirm that the files from winter season shows the data inconsistently, Total Commander and MM5 shows 00:22 while Windows Explorer shows 23:22
This is quite strange, because for newly created files the value is same in Windows Explorer, Total Commander, MM5.
image-3.png (45,557 bytes)   
image-3.png (45,557 bytes)   

zvezdan

2022-05-25 17:29

updater   ~0068248

There is an option in Total Commander called "NTFS daylight saving correction", which results with the same time as with Windows Explorer.

zvezdan

2022-05-25 17:31

updater   ~0068249

And I suppose your "newly created files" have a summer Date Modified time. Unless you are living in south hemisphere :)

Ludek

2022-05-25 19:57

developer   ~0068261

Fixed in 5.0.4.2650