View Issue Details

IDProjectCategoryView StatusLast Update
0019089MediaMonkey 5Main Panelpublic2022-05-30 14:24
Reporterzvezdan Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019089: Label and tracks for audio CD not updated when the drive is selected under the Folders node (upon inserting)
DescriptionDrives with removable discs are not working as they should. I have attached the series of screenshots showing MM5, MM4 and Windows Explorer:
1. nothing in a CD drive;
2. inserted audio CD -> MM5 doesn't show that anything changed;
3. changed node in the tree to another drive and back to CD drive -> MM5 shows tracks, but the disc label is missing;
4. restarted MM5 -> it shows tracks and the label (Audio CD);
5. removed disc -> MM5 still shows tracks and Audio CD label from the previous disc;
6. changed node to another drive and back to CD drive -> MM5 doesn't show tracks, but it still shows Audio CD label from the previous CD;
7. inserted CD-ROM disc with mp3 files -> MM5 still doesn't show files and it still shows Audio CD label from the previous CD;
8. changed node to another drive and back to CD drive -> MM5 shows files, but it still shows Audio CD label;
9. restarted MM5 -> it shows files from disc and its label.

Note that MM4 and Windows Explorer showed correctly files and disc label in all these cases.
TagsNo tags attached.
Fixed in build2650

Relationships

related to 0019090 feedbackLudek filesystem.driveIsReady method needed 

Activities

zvezdan

2022-05-27 18:50

updater   ~0068308

I made it private because I didn't want for anyone to see my screenshots, but only you. But now I don't see the screenshots attached at all. Did you receive them?

Ludek

2022-05-27 18:52

developer   ~0068309

I can cofirm that once the 'Audio CD' node added sub to the root node in Media Tree shows correct info after inserting the CD
=> The node is added with the Audio CD info

BUT, the same node under the Folders node fails to update the info.

WORKAROUND: Collapse the Folders node and expand it again.

zvezdan

2022-05-27 18:55

updater   ~0068310

MM4 and Windows Explorer don't need any workarounds for such thing. And as I mentioned such workaround helps only to refresh the tracklist, but not the label of the disk. For that you need to restart the program, which hardly could be called a workaround.

Ludek

2022-05-27 18:58

developer   ~0068312

image.png (25,759 bytes)   
image.png (25,759 bytes)   

Ludek

2022-05-27 18:59

developer   ~0068313

Last edited: 2022-05-27 19:01

View 3 revisions

Sure, as I wrote it is just a refresh issue under the Folders node (per my image above), to be fixed...

EDIT: For me collapsing the Folders node and re-expanding refreshes the label fine for all drives.

Ludek

2022-05-27 19:23

developer   ~0068315

Re screenshots: No, I don't see any of your screenshots.
I don't think that one can attach screenshot to a private note or an private issue.
At least I can't

Ludek

2022-05-27 20:01

developer   ~0068317

Last edited: 2022-05-27 20:01

View 2 revisions

Fixed in 5.0.4.2650

zvezdan

2022-05-29 14:58

updater   ~0068323

You shouldn't change the original summary of this issue. The problem is not only with Audio CDs, but with all removable drives. I don't know if your mentioned update will have fixed it for such drives as well. I have one quite long animated screenshot proving that, I will attach it in the next post.

zvezdan

2022-05-29 15:09

updater   ~0068324

I forgot to include the view of the Medias table for MM4 and MM5 in the animated screenshot. I have them added as individual screenshots.

As you could see from these screenshots, MM5 has problem not only with not detecting label of a drive and files in the tracklist, but:
1. it has wrong serial number and label stored in the Medias table;
2. it has all tracks added to the same drive, even when I replaced "discs" (you should look the whole animated screenshot until the end).
2022-05-29_16-43-40.gif (4,059,408 bytes)
screenshot.20.png (20,496 bytes)   
screenshot.20.png (20,496 bytes)   
screenshot.19.png (19,770 bytes)   
screenshot.19.png (19,770 bytes)   

Ludek

2022-05-30 14:24

developer   ~0068329

It all should be already fixed in 5.0.4.2650.

Please re-test in 5.0.4.2650 (once is availbale) and re-open in case you still see issues (or enter it as another issue).