View Issue Details

IDProjectCategoryView StatusLast Update
0019081MediaMonkey 5Playlists (Auto) / Search / Filterspublic2022-05-24 22:28
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Target Version5.0.3Fixed in Version5.0.3 
Summary0019081: Tracks from search results are sometimes not displaying
DescriptionAfter using global search, MM5 displays Artists, Albums and Tracks matching search string. But sometimes tracks are not visible, or only first 1-2 found tracks are visible. It seems to be issue with setting correct tracklist height, it is sometimes fixed after moving splitter (but not always, sometimes user has to do search again).
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=497653#p497653
TagsNo tags attached.
Fixed in build2627

Activities

michal

2022-05-19 11:39

developer   ~0068164

Fixed in build 2626.

peke

2022-05-20 19:19

developer   ~0068193

Verified 2626

Unable to replicate exact user case but @Michal test case can happen in 1/5 times in 2625 but not in 2626 retest and close before release.

peke

2022-05-22 17:07

developer   ~0068201

I am able to replicate user https://www.mediamonkey.com/forum/viewtopic.php?p=497784#p497784 description with search watch for diacritics, but it happen only when Column filter is enabled and if column filter is disabled then global search works normally.

Also Redone full text Search helped and it happen in 1/10 test.

I guess that there is still some small regression left.

Note: I tested using 2616, 2619, 2622 (user claims it work there for him), 2625 and 2626 and all behaved same for me.

michal

2022-05-23 11:13

developer   ~0068203

Last edited: 2022-05-23 14:58

View 2 revisions

I am finally able to reproduce it more frequently - with larger DB, in both List or List (by Album), with column filter on, search with diacritics, global search, when search was initiated just after starting the app.
Search with diacritics is significantly slower, this could affect timing and causes that problem is reproducible with this setting. When ignoring diacritics the search is very fast and I was not able to reproduce it.

michal

2022-05-23 14:54

developer   ~0068205

Fixed in build 2627.

peke

2022-05-24 22:28

developer   ~0068225

Verified 2627

Unable to replicate while testing all variations noted by me (with and without diacritics enabled searches) and/or user in at least 30 tries and restarts of MM5.