View Issue Details

IDProjectCategoryView StatusLast Update
0018699MediaMonkey 5DB / Backuppublic2022-05-20 19:34
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.4Fixed in Version5.0.3 
Summary0018699: Closing the DB/Settings import dialog can eventually result in a crash
DescriptionIf the user closes the DB/Settings import dialog, then MM appears to immediately close (even though it's still running a it reverts DB changes). So if the user runs MM at this point, it can cause a crash due to both instances running as the db is being reverted.

Possible solutions discussed:
a) Provide the user with feedback that MM is still running (so they don't start a new instance) e.g.
 - Change the dialog to 'Reverting...' and reverse the direction of the status indicator until the process completes
b) Remove the 'Cancel' button
TagsNo tags attached.
Fixed in build2626

Relationships

related to 0018696 closedLudek Crash if Library update is closed 

Activities

Ludek

2021-12-22 20:44

developer   ~0066479

Eventually we could unify it with the "rebuild DB" progress like this: https://www.dropbox.com/s/mobvgkynaup05zz/Screenshot%202021-12-22%2021.11.01.png?dl=0
i.e. no close/cancel button.

Ludek

2022-05-20 13:51

developer   ~0068189

Fixed in 5.0.3.2626.

Unified with the "rebuild DB" progress so looks like this: https://www.dropbox.com/s/lzr226arbdoimeg/Screenshot%202022-05-20%2015.50.29.png?dl=0

peke

2022-05-20 19:34

developer   ~0068198

Verified 2626

Test note use older MM5 version or Import MM4 library.