View Issue Details

IDProjectCategoryView StatusLast Update
0018688MediaMonkey 5Playbackpublic2022-01-21 03:56
Reporterdrakinite Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.2 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018688: Play/Pause button displays wrong state when skipping to start of track
DescriptionTo reproduce:
1) Pause track in the middle.
2) Press the Previous button to skip to the beginning.
The button changes from Play to Pause, instead of staying Play (because the track remains paused).
TagsNo tags attached.
Fixed in build2602

Activities

michal

2021-12-20 16:53

developer   ~0066434

Fixed in build 2600.

lowlander

2022-01-06 19:47

developer   ~0066536

Verified that Play/Pause button works as expected on 2600.

However the seekbar does not return to the beginning when pressing the Previous button. It does this when resuming playback.

michal

2022-01-07 18:06

developer   ~0066574

It seems to be file format specific, I cannot reproduce with MP3, but can with FLAC or OGG.

michal

2022-01-07 19:26

developer   ~0066579

Fixed in build 2601.

lowlander

2022-01-13 22:01

developer   ~0066621

Verified that with those steps the seekbar does reset to the start, however on initiating playback there is a seemingly a short blip (probably audio from where file was paused) and then playback starts normally (FLAC).

Also it still fails if:
1 Play file
2 Pause file
3 Seek to middle of file
4 Use Previous to reset to start of file
--> Seekbar does not update to start, but playback does start then when restarted

michal

2022-01-18 13:42

developer   ~0066660

Fixed in build 2602.

peke

2022-01-21 03:56

developer   ~0066704

Verified 2602

State is ok.