View Issue Details

IDProjectCategoryView StatusLast Update
0018662MediaMonkey 5Extensions frameworkpublic2022-07-04 21:59
Reporterdrakinite Assigned To 
PriorityurgentSeverityminorReproducibilityN/A
Status closedResolutionreopened 
Product Version5.0.2 
Target Version5.0.4Fixed in Version5.0.4 
Summary0018662: Add an option to hide bundled addons
DescriptionAs the addons list is full of bundled addons now, most of which don't need to be viewed or modified, it can become difficult to find third party addons. We should add a checkbox at the top of the dialog, auto-checked by default, with the text "Show bundled addons" or "Include bundled addons". This will allow the user to de-clutter their list of addons to the ones they care about adding/removing.
TagsNo tags attached.
Fixed in build2656

Activities

rusty

2022-04-20 01:34

administrator   ~0067605

Currently we refer to 'Core' addons as addons that are key to MM functionality.
We could refer to 'Bundled' addons for all addons that are included (i.e. Core addons + all other bundled addons).

In which case "[ ] Hide bundled addons" would work.

However, if we implement this, then I suppose that:
- Clicking Show: _Update available_ OR '[Find updates]' should deselect '[ ] Hide bundled addons' (otherwise updates to bundled addons wouldn't display)
- Clicking Show: _Configurable_ deselect '[ ] Hide bundled addons' (otherwise configurable items wouldn't display)
This is kind of kludgy, so if you have a better idea...

barrym

2022-04-20 13:37

reporter   ~0067607

I agree the general point that the Addon screen is a mess. with a lot of information, that I don't need, making it more difficult to manage the things that I do need to control.

The facility has a Show Dropdown Control. You could introduce another section into that same dropdown list, which introduces a new additional way of filtering Addons.
SHOW:
* USER Installed Addons
* Addons shipped with MM5
-----------------------
* ALL Add-on categories
* Configurable
* Skins
etc

I would default the filter to "USER Installed Addons" ... currently the default is ALL

You could also introduce a third category filter into that same dropdown list; "Add-ons where updates are available"
If the User selected that filter you could auto-trigger an update check for all addons (ie. shipped and user-installed), and filter the display to just those where an update exists.

drakinite

2022-06-15 22:30

developer   ~0068549

Last edited: 2022-06-15 22:34

View 2 revisions

I think a combination of Rusty's and Barry's suggestions would work:
1. Add a second dropdown, titled "Filter", with "Core addons", "Bundled addons", and "User-installed addons".
2. Move "Update available" to the new dropdown, because it's filtering based on its "status" rather than its category.
3. Move "Configurable" to the new dropdown, for the same reason.
3. (maybe?) Rename "Show:" to "Category:" (or "Type:", since we already have translations for that),

so either we have
Show: [All, Skins, Layout, Plugin, ...] Filter: [All, Configurable, Core addons, Bundled addons, ...]
or
Type: [All, Skins, Layout, Plugin, ...] Filter: [All, Configurable, Core addons, Bundled addons, ...]
or, perhaps...
Type: [All, Skins, Layout, Plugin, ...] Show: [All, Configurable, Core addons, Bundled addons, ...]
image.png (161,210 bytes)   
image.png (161,210 bytes)   

rusty

2022-06-16 15:58

administrator   ~0068558

I actually prefer Barry's suggestion, since it's simpler and would (I think) meet user needs faster. Also, the terminology is clearer.

e.g. if the user wants to:
- Update/Uninstall one of their user-installed addons, they can do so from the default view (Show: 'User-installed')
- Update all addons, they can do so from the default view (via 'Find updates', which would switch to the 'Update available' view)
- Configure an addon, they can use the 'Configurable' (no change required)

As to the need to show/hide bundled/core addons within a category, I don't think that'll prove necessary once 'User-installed' is available.

jiri

2022-06-20 08:18

administrator   ~0068604

Wouldn't a hardcoded list of addons that we consider bundled be easier to maintain? This way we can modify (both add and remove) the list easily with each build, in case it's necessary.

Ludek

2022-06-20 10:46

developer   ~0068608

Last edited: 2022-06-20 10:51

View 3 revisions

It's already "hardcoded" as the bundled addons are included within the install folder -- while the user installed addons have different install location(s).

So my undestanding from the notes above is that we will just introcude new dropdown option 'User-installed'
i.e.
Show: [User-installed]
will show just the addons installed by user (outside of the MM5 install folder)

Ludek

2022-06-20 14:38

developer   ~0068614

Fixed in 5.0.4.2654

peke

2022-06-24 21:56

developer   ~0068683

Last edited: 2022-06-24 21:57

View 2 revisions

Verified 2655 option is working,

I only wonder if Codec pack should be excluded from bundled list and be shown as User-Installed?

Ludek

2022-06-27 12:19

developer   ~0068702

Good catch, fixed in 2656

peke

2022-07-04 21:59

developer   ~0068772

Verified 2656

All Ok now.