View Issue Details

IDProjectCategoryView StatusLast Update
0018646MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-12-14 19:03
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018646: Background metadata lookup: Overwriting unsaved lyrics with new lyrics fails
DescriptionIf the user has enabled Options > Background metadata lookup:Lyrics (without 'Update tags'), then editing the lyrics fails to save the changes. e.g.

0 Enable Options > Background metadata lookup:Lyrics / Disable 'Update tags'
1 Right-Click Preview:Selected > Properties
2 Edit the lyrics of the selected track and click 'OK'
--> Preview window continues to show the incorrect looked up lyrics

Note:
- If the user edits the lyrics in the Preview window then they're updated as expected
- If the user edits the lyrics in the Properties:Lyrics tab and clicks the 'Save lyrics' icon, then they're saved

The fix would be that if the Lyrics are 'unsaved' and the user makes a change to the looked up lyrics, then they should automatically change to the 'Saved' state when the user commits the change.

Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=100839
TagsNo tags attached.
Fixed in build2527

Relationships

related to 0017890 closedmichal Lyrics Search: Found lyrics with Auto lyrics search is not propagated to track properties 
related to 0018645 closedmichal Background Metadata Lookup: lyric (and Album art) lookups are repeated after user has deleted poor results 
related to 0018663 closedmichal Deleting all lyrics fails 

Activities

michal

2021-12-09 10:07

developer   ~0066311

Fixed in build 2527.

lowlander

2021-12-10 00:47

developer   ~0066335

Last edited: 2021-12-10 00:51

View 2 revisions

Verified on 2527, looked up, unsaved Lyrics are saved if user edits the Lyrics and this is reflected in the Preview window.

Original issue of not being able to delete Lyrics is unresolved, but tracked in 0018645

As for "Unfortunately even after Background metadata lookup:lyrics is unchecked, it still will not save any edit to lyrics..." it works on 2527. Deleted Lyrics remain deleted when lookup is disabled

rusty

2021-12-14 19:03

administrator   ~0066387

Re-verified in 2528 due to changes at 0018663