View Issue Details

IDProjectCategoryView StatusLast Update
0018627MediaMonkey 5Playlistspublic2022-05-25 15:03
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018627: MM creates "recently added" playlist even though I asked it not to
DescriptionAs in title. After I sync, a new playlist appears, called "Added from Galaxy A12 on 2021-12-06", even though Tools-->Options-->Tags & playlists-->Create playlists of tracks newly added to the library is deselected.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=100806
TagsNo tags attached.
Fixed in build2618

Relationships

related to 0010958 closedLudek MediaMonkey 4 Files copied from device -> PC are recopied when deleted in device 

Activities

Ludek

2021-12-06 18:55

developer   ~0066243

Last edited: 2021-12-06 18:57

View 2 revisions

Fixed in 5.0.3.2600

I am just not sure about the fix, as adding the "Added from Galaxy A12 on 2021-12-06" playlist also adds this playlist to Sync-list per 0010958
so that the newly added tracks are not subsequently deleted from the device when 'Delete unselected library files' feature is enabled.

Which won't be the case anymore with the "Create playlists of tracks newly added" config disabled (by default).
On the other hand it is probably right and logical to respect this settings.

Assigned to Rusty for feedback with 5.0.3 target

rusty

2022-04-20 22:56

administrator   ~0067646

Last edited: 2022-04-21 21:34

View 2 revisions

I'm not sure what the fix was. Can you clarify? Are you saying that you changed the original approach to fixing 0010958 and that issue has been re-opened? If not, could we just make some changes to text/tooltips for 5.1?

For the tooltip for "Auto-sync playlists and new files from the device to the PC"

Syncs files from the selected folders on the device to the PC.
-->
Syncs files from the selected folders on the device to the PC. + "A playlist is automatically created for each set of files added."

--
In Tools > Options > Tags & playlists:

Create playlists of tracks newly added to the library
-->
Create playlists of files newly scanned to the library

Ludek

2022-04-22 10:19

developer   ~0067672

Last edited: 2022-04-22 10:21

View 2 revisions

The fix was that once
Tools-->Options-->Tags & playlists-->Create playlists of tracks newly added to the library
is disabled then MM5 no longer creates playlists like "Added from Galaxy A12 on 2021-12-06"
and thus such a playlist isn't auto-added to Sync-list (Library --> Device)
So once user enables [x] Delete other files and playlists from device: [Unselected library files]
it will want to delete the files previously added from the device to the local library, i.e. it will want to delete the files from the device and keep them in the local library only.
This might be expected for some, but unexpected for others.

Therefore I am not sure about the fix and maybe we want to revert the fix and always create the "Added from Galaxy A12 on 2021-12-06" playlists and auto-add such a playlist to 'Sync-list (Library --> Device)' for the reasons described above.

rusty

2022-04-25 22:04

administrator   ~0067780

This will mainly affect users that use a third party client (e.g. Apple Music or a Pocast app) to download content locally and then sync it with MMW. The challenge is that users with large collections require use of the 'Delete tracks not on the sync list' functionality, and this change will result in:
a) tracks (possibly very large numbers of them) being deleted from the portable device
b) possible? sync issues with their third party client. i.e. unless there's a 'download all tracks since the last download', the client may re-download all tracks (as they're no longer in their expected location) causing track duplication issues

So it's hard to know for certain, but I suspect that the fix might be worse than the initial problem. Possible resolutions would be to:
1 a) Undo the fix and update documentation for 5.0.3 and make the string/tooltip changes suggested at 0018627:0067646 in 5.1
. b) Add a configuration flag if users want to change the default behavior in 5.0.3 e.g.
 [x] Create playlists of tracks newly added to the library (Recommended) [Tooltip: Required if you wish to exclude tracks originating on the device from deletion rules.]
OR
2) Modify the 'Delete other files and playlists...' functionality with the ability to exclude certain folders.

Ludek

2022-04-27 14:39

developer   ~0067823

OK, I've reverted the fix in 2618 (solution 1a) for the reasons described above, added todoc flag.

peke

2022-05-01 16:08

developer   ~0067896

Verified reverted fix in 2619

peke

2022-05-11 15:45

developer   ~0068092

Re verified 2624

lowlander

2022-05-25 15:03

developer   ~0068236

Help doc updated to specifically refer to scanning being affected by this setting.

String remains to be updated to "Create playlists of files newly scanned to the library"