View Issue Details

IDProjectCategoryView StatusLast Update
0018623MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-12-08 03:06
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018623: Auto-tag stops working and subsequently crashes
DescriptionIn some situations, auto-tag behaves strangely, and auto-tag operations subsequent to the initial one behave erratically and/or trigger a crash. I haven't figured out the exact repro steps yet nor with a debug log, but I'll document what happened in case this is helpful:

0 Running MM (standard)
1 Initiate auto-tag on 38 tracks that are from multiple albums and multiple directories (some of which may have been having their audio analyzed concurrently)
2 In the first batch of 20, deselected 3 of the tracks since they were bad guesses, and attempted to look up the fingerprint for one other track
--> Even though only 1 track was being looked up, and the status bar indicated one track was being looked up, multiple tracks appeared in the status bar (it seemed to be cycling through all tracks with the same artist name)
--> After the fingerprint lookup completed (unsuccessfully), multiple tracks became deselected!
3 Reselected the tracks to be tagged and clicked 'Tag and Continue'
--> The next batch of 18 tracks appeared and were being looked up BUT they weren't grouped by albums! i.e. the tracks had album metadata looked up, but even though they were from about 10 different albums, they were grouped into 2 sets (which also meant that most were missing album art.
4 Clicked cancel, because something obviously went wrong
5 Reselected 10 of the 18 tracks that were still missing metadata and initiated auto-tag
--> Lookups occurred, but upon clicking 'Tag', the metadata failed to update
6 Repeated step 5
--> MediaMonkey became a blank white screen

I'm really not sure what the problem was, but it seems likely that the operations at steps 1 and 2 somehow 'broke' Auto-tagging, and caused subsequent operations to fail and then crash. Possible triggers to investigate:
a) initial set larger than the maximum auto-tag batch size - RULED OUT
b) tracks in different batches of an auto-tag operation are from the same album - RULED OUT
c) editing looked up values OR looking up fingerprints from the first batch of a multi-batch lookup - RULED OUT
 - during the auto-tag lookup
 - after the auto-tag lookup
d) auto-tag of tracks whose volume is being analyzed -- RULED OUT
e) auto-tag of tracks that are in an Auto-playlist that is currently in view - RULED OUT
f) auto-tagging classical tracks which seems to cause lyric lookups 5 times for each track - RULED OUT
Additional InformationOriginally reported at ticket # 2883
TagsNo tags attached.
Fixed in build2525

Relationships

related to 0018629 resolvedpetr Auto-tag: Lyrics are looked up multiple times from the same source 
related to 0018594 closedpetr Crash 4E550000 

Activities

rusty

2021-12-06 18:08

administrator   ~0066241

Last edited: 2021-12-06 19:13

On further testing, the bug can be replicated via a much simpler set of steps:
0 Run MM (not Gold)
1 Select 8 tracks (no classical tracks) and initiate auto-tag
--> Tracks are looked up
2 Select all tracks and click [Cancel]
3 Repeat the above
--> Lookup proceeds in 2 batches of 4 tracks!
4 Click [Skip and continue] after the first batch
5 Click [Cancel] after the second batch
6 Repeat Step 1
--> the out of memory bug occurs!

This is kind of strange, since I'd been using auto-tagging successfully and without seeing this issue for months. The only item that may be different is that I'm now testing without a Gold license activated.

I've updated the initial report to reflect ruling out all the other hypotheses. And opened/re-opened
0018629 - to track the issue re. lyrics being looked up multiple times
0018567 - to track the 'stuck' dropdown

petr

2021-12-06 21:12

developer   ~0066249

Fixed

rusty

2021-12-08 03:06

administrator   ~0066277

Verified 2525: batch sizes no longer get confused (tested with Standard version of MM), and auto-tagging multiple batches/times doesn't trigger a crash.