View Issue Details

IDProjectCategoryView StatusLast Update
0018619MediaMonkey 5Syncpublic2021-12-09 11:21
ReporterLudek Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018619: iPod restored in the newest iTunes breaks compatibility with MM
DescriptionThis was originally reported by user [Ticket # 3229] with iPod Nano 6

I replicated the same with 'iPod Nano 7' this way:

1) Download newest iTunes 12.12.2
2) Restore the iPod in iTunes and sync a single track using iTunes
=> track is visible/playable by iTunes
3) Sync another track using MediaMonkey
=> iPod shows there is no music !!

Additional InformationProbably the same issue in [Ticket # 3206]
https://www.mediamonkey.com/forum/viewtopic.php?f=12&t=100827
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100727
TagsNo tags attached.
Fixed in build2525

Relationships

related to 0016998 assignedLudek MediaMonkey 5 iOS sync: iTunes does not see music synced by MediaMonkey 
has duplicate 0018632 resolvedpeke MediaMonkey Addons iPod restored in the newest iTunes breaks compatibility with MM4 

Activities

Ludek

2021-12-05 18:31

developer   ~0066231

Fixed in 5.0.2.2525

Ludek

2021-12-05 18:56

developer   ~0066232

BTW: For the MM4 the fix is within this d_iPod.dll : https://www.dropbox.com/s/0pob0kr5qsetxnm/d_iPod.dll?dl=0

@Peke, please bundle this d_iPod.dll with the https://www.mediamonkey.com/addons/browse/item/iphone-ipod-plug-in/
And probably also to https://www.mediamonkey.com/addons/browse/item/iphone-sync-plug-in/

peke

2021-12-06 11:41

developer   ~0066235

Assigned to me to create MMIP for d_ipod mmip.

PLease let me know just how to set versions of plugin and if it also involves d_iphone or just d_ipod, because if d_iphone is not affected then I will create new MMIP just for d_ipod?

Ludek

2021-12-06 12:45

developer   ~0066236

Yes, this bug is just about d_iPod.dll

Ludek

2021-12-06 13:42

developer   ~0066238

FYI: Both the users already confirmed the fix ( [Ticket # 3206] with iPod classics + [Ticket # 3229] with iPod Nano 6 )

peke

2021-12-08 14:30

developer   ~0066286

Verified 2525

Tested on iPod Touch 4G.

Test Note: If there was working iPod Restore is a MUST step to replicate error in build 2524

rusty

2021-12-08 15:06

administrator   ~0066292

Last edited: 2021-12-08 15:07

View 2 revisions

I also verified this on an iPod Nano 3G (updated to 1.1.3 firmware).

Ludek

2021-12-09 11:21

developer   ~0066312

Yes, restoring in the newest iTunes is the needed step.