View Issue Details

IDProjectCategoryView StatusLast Update
0018545MediaMonkey 5Main Panelpublic2022-10-19 17:48
ReporterLudek Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.4Fixed in Version5.0.4 
Summary0018545: Add 'Artist only' node
DescriptionIn MM5 we replaced so called "Artist & Album artist" node in MM4 by "Artists" node than now includes both 'Artists' and 'Album artists'
Later we added configurable 'Album artist' node to show only those artists that are "Album artists"

But it seems that some users are missing "Artist only" node that would show artists that are not "Album artists"
Requested here: https://www.mediamonkey.com/forum/viewtopic.php?p=489769#p489769
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=100541
TagsNo tags attached.
Fixed in build2669

Relationships

related to 0018544 closedLudek MediaMonkey 5 DLNA: Shared content behavior is not same as in MM collections locally 
related to 0019161 closedmartin MediaMonkey for Android Artists / Album Artists terminology should be the same in MMW and MMA 

Activities

Ludek

2021-11-12 17:22

developer   ~0065898

Assigned to Rusty to triage wording.

peke

2021-11-12 18:44

developer   ~0065905

Last edited: 2021-11-12 18:46

As Jiri explained in 0014747:0050028 adding additional node would be adding too much complexity and it would be much easier and clean that

If user enable showing "Album Artist" Tree node then "Artist" tree node shows only Artists not Artist and Album Artist (default).

Enabled Tree node Behavior:
Only Artist Tree node enabled -> Artist: Shows Artist and Album Artist
Artist and Album Artist Tree nodes enabled -> Artist: Shows Artist only, Album Artist: Shows Album Artist

(?) Only Album Artist Tree node enabled -> Artist: Shows Artist and Album Artist

Same thing should propagated to DLNA.

NOTE this behavior is from MM 5.0.1 When we fixed all leftovers from MM4.

Ludek

2021-11-12 18:53

developer   ~0065908

I don't think that we were ever changing bahaviour of the 'Artists' node depending on a visibility state of the 'Album artist' node.
This would be more like a bug IMO (and rather unexpected).

rusty

2022-04-20 16:16

administrator   ~0067616

There are 2 possible approaches:
a) use 'Contributing artists' to refer to artists only. BUT, if we did that, we'd probably have to change change field descriptions, masks, etc. that refer to artists only. e.g. Properties dialog: Artist(s) --> Contributing artist(s) , which is likely to introduce some unintended consequences.

b) Add an 'Artists only' node as an option and
ii) Add a tooltip for the the current 'Artists' node: 'Artists and Album Artists'

The second approach is less technically correct, but probably the preferred one.

Ludek

2022-06-06 12:30

developer   ~0068436

OK, so the question is whether there is another localization round planned for 5.0.4 as both 'Artists and Album Artists' and 'Artists only' are new strings.

Another alternative for 'Artists only' could be 'Track artists''.
Even "Contributing artists" would be probably fine (despite the fact whether we use this string just for this tree node or globally).

rusty

2022-06-27 17:28

administrator   ~0068706

I think we can ask users to make a few string updates for something as important as this.

Also, I agree with Ludek's suggestion to use 'Contributing artists' (or Artists (contributing)) + tooltip. i.e.

Existing Node: 'Artists' add a Tooltip: 'Artists & Album artists'
New Node (not enabled by default): 'Contributing artists', Tooltip: 'Artists only'

Note: we may also want to display the tooltip strings in the Collection Options > Subnodes configuration panel in cases where the tooltip doesn't match the node so that users understand what these nodes are as they configure them. e.g.
All tracks
...
Title
Albums
Genres
Artists (Artists & Album artists)
Contributing artists (Artists only)
...

Ludek

2022-06-28 16:13

developer   ~0068726

Implemented as sugegsted in 5.0.4.2656

peke

2022-06-28 23:42

developer   ~0068732

Last edited: 2022-06-29 23:54

Maybe it would be better to use common name [url=https://id3.org/id3v2.4.0-frames [TPE1 Lead performer(s)/Soloist(s)] as "Contributing Artist" for me when translation means More like "Featured Artist".

Main problem is that: "Contributing Artist", "Lead performer" and "Featured Artist" can mean same thing in different context :(

Other than that I agree on tooltips and their content.

EDIT: Maybe even use "Featured Artist" (Artists & Album Artists), "Artists" (Track Artists only)?

barrym

2022-07-09 08:46

reporter   ~0068791

apologies for contributing an opinion so late here. I find this forum hard to navigate.

I don't think that Contributing Artist is a good name for this new node either.
I am also immediately thinking of Featured Artist or the Involved People tag,

My suggestion is Track Artists ... or Track Artists Only if there was sufficient space

I am presuming that people have asked for this node to filter out any whole album level tags, like Various Artists etc. So that name makes more sense to me.
I don't really understand the requirement, but ....

nb. Referring back to the Jiri note (referred to above); I agree that 3 nodes is messy (ie. Artist, AlbumArtist, and this new thing).
He said that AlbumArtist node may not be necessary.
I don't know if this still on the table.
This is something that I do feel strongly about. It is important that the AlbumArtist node be retained, ie. an index that is not polluted by all the many artists who have contributed just a single track to things like Soundtracks albums, or Genre based albums. IMO MM5 conditional syncing was crappy to use before you reinstated the AlbumArtist index into MM5.

The other reason is that some people (ie. like me) have set the Artist tag according to community expectations, because this is the Tag that is scrobbled to the LFM database.
But I set the AlbumArtist tag to how I privately see the artist. I then navigate in MM5 using the AlbumArtist tag exclusively.

Example: Miles Davis published albums under his own name, and as Miles Davis Quartet and as Miles Davis Quintet, etc
I label all the track Artist tags "correctly", as per what was printed on the album cover, but my AlbumArtist tag is always "Miles Davis"
The AlbumArtist node is important to disambiguate my own collection.
And the artist tag is important to disambiguation the public collection, ie. the LFM database

rusty

2022-09-13 19:39

administrator   ~0069233

I understand that some users may not initially understand that Contributing artists refers to Artists, but it _is_ the term used in Windows File Explorer, and we show the 'Artists only' tooltip to clarify. (I agree that 'Track artists' could be a good alternative, but they don't always apply to a 'track' (e.g. it could apply to a podcast or an audiobook which is why we want to get away from using that terminology).

So I'd leave this as is unless someone has a better idea.

peke

2022-09-30 20:13

developer   ~0069596

Last edited: 2022-09-30 20:35

Verified 2667

Using F1 on selected contributing artist redirects to https://www.mediamonkey.com/webhelp?hp=Content&vmaj=5&vmin=0&vrel=4&lang=en which is non existing page.

I guess that at least it should point to https://www.mediamonkey.com/wiki/WebHelp:Library/5.0

EDIT: Help handled in 0019415

peke

2022-09-30 20:33

developer   ~0069602

Each node (Artists (both), Contributing Artists (Artists only), Album Artists) when enabled show correct information and subnodes.

Help for https://www.mediamonkey.com/wiki/WebHelp:Library/5.0#Artists,_Album_Artists,_Composer_and_Conductor should be updated to include "Contributing artist"

rusty

2022-10-01 23:32

administrator   ~0069607

Last edited: 2022-10-02 17:55

This isn't resolved in my environment (or in Martin's):
- Contributing Artists node displays Album Artists (both in the tree and in the list).
- Clicking the Album Artist triggers a crash A14ADE05

EDIT: Peke has confirmed that the issue does _not_ occur for him, so perhaps it's database-specific. Please let me know if you need a copy of my DB.

Ludek

2022-10-03 12:34

developer   ~0069621

Fixed in 2668

rusty

2022-10-04 19:54

administrator   ~0069641

Verified 2668.

rusty

2022-10-06 02:44

administrator   ~0069658

Last edited: 2022-10-06 02:45

Retested based on LL's feedback and it seems that the 'Contributing Artists' node is missing many artists.

I believe that the root of the issue is the phrasing of the requirement. The intent was for the node to show Artists (like in MM4) i.e. _even_ if they're missing an 'Album Artist' field--every Artist in the library should appear in this node. That way if e.g. 'Redman' is a contributing artist on an 'Eminem' album or an album by 'Eminem & Redman' or Eminem;Redmon, it would appear sub to contributing artists.

Ludek

2022-10-06 11:42

developer   ~0069664

Last edited: 2022-10-06 11:45

OK, reverted the behavior change from 2668.

=> in 2669 it shows also Artists that are Album artists.
i.e. if 'Various Artists' is within 'Artists (s)' field then it is shown in 'Contributing Artists' despite it is also Album artist or not.
That said it behaves like the Artist node in MM4.

lowlander

2022-10-06 20:29

developer   ~0069677

Verified on 2668,