View Issue Details

IDProjectCategoryView StatusLast Update
0018530MediaMonkey 5Syncpublic2022-02-15 14:29
Reporterbarrym Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformWindowsOS-OS Version10
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018530: Sync status bar is visible only if Player panel is visible
DescriptionThe Status bar seems to be imbedded into the Player panel.
No Status bar if the Player panel is disabled ... Is not enough to just have the Bottom panel enabled.
If I move the Player panel to the Top Panel, the status bar moves with it.

Acknowledged that the Status bar may be displayed in the spinning wheel's tool tip.
But the Status bar has important information in a long running sync operation, and a customer who does not use MM5 as a play client would not know that a Status Bar exists.
Tested with with 2516, Code Monkey skin, and sync to Google Drive.
Main panel is displaying the LibraryContent tab od D&S>GoogleDrive


TagsNo tags attached.
Fixed in build2605

Relationships

related to 0018240 closeddrakinite Background tasks circle icon cannot be used to terminate all tasks 
related to 0018845 closedmichal Crash when switching to touch mode - regression 

Activities

petr

2022-01-18 14:17

developer   ~0066662

Every skin can define where progresses should be visible using DIV element with data-id 'progressContainer'. When there's no element with this id, new is created at the bottom of the DOM (not in the dock) so it is ALWAYS visible at the most bottom of the main window.

rusty

2022-01-18 15:37

administrator   ~0066666

i.e. this issue is likely specific to the 'Code Monkey' skin.

barrym

2022-01-19 01:36

reporter   ~0066671

It is not only related to the CodeMonkey skin. I still see the issue with the Monkey Groove skin which is installed by default. ... tested with 2531

I will put a request into the CodeMokey thread to correct the issue.
The issue is debilitating because there is no way to cancel a sync operation unless you know the trick re the bottom Player panel visibility.

In skins that don't have have this problem the current implementation is fairly ugly ... ie. the status bar overwrites other data, and is hard to read. See attached image.

"When there's no element with this id, new is created at the bottom of the DOM (not in the dock) so it is ALWAYS visible at the most bottom of the main window."

I don't fully understand all what is quoted above, but the statement seems false to me. ... ie. nothing is visible in CodeMonkey and Monkey Groove.

barrym

2022-01-20 08:03

reporter   ~0066678

The author of the CodeMonkey skin responded
https://www.mediamonkey.com/forum/viewtopic.php?p=493462#p493462

It seems as if there is in inadequacy in the MM skin framework that hampers skins from delivering a reliable and readable status bar for long running background task.

I took the liberty of re-opening the issue because it seems like comments to closed issues are invisible.

It seems to me that a response of "no change required" is inadequate.

1. A long running batch task requires a status bar so the User can see sign of life, and monitor progress , and to gain access to the Cancel option... It is illogical that this be available contingent upon the Player panel be on display.
2. The Status bar is available on the default skin, when the Playing screen is disabled, but the status bar is illegible and is ugly (see attached pix)
3. The Monkey Groove has no Status bar when the Playing panel is disabled
4. The response is "When there's no element with this id, new is created at the bottom of the DOM (not in the dock) so it is ALWAYS visible at the most bottom of the main window." ... maybe I misunderstand, but if this statement was true, why don't I see this created thing in the Monkey Groove and CodeMonkey skins?
4. Reportedly the see existing framework creates difficulty for Sking authors, see TIV73's comments in the above link.
status bar is overwritting.png (52,682 bytes)   
status bar is overwritting.png (52,682 bytes)   

drakinite

2022-01-20 20:01

developer   ~0066692

I believe the most important thing is to allow the user to right click > Cancel all on the tasks controller on the top bar. This I can do.

Next, I believe it's up to the skin maker whether they want their task progress container to be inside the player or not. The issues Barry brought up are valid, and I think it's worth changing our bundled skins to make the task progress bar always visible, on the bottom of the screen. I'll take this issue and try to add both.

drakinite

2022-01-21 01:21

developer   ~0066697

Fixed in 5.0.3; updated Dark Monkey release on addons site.
To fix the ugly clipping issue, the task progress bar now has its own area on the bottom of the screen when any are visible. This can be disabled by skin makers by adding the following code in controls/taskscontroller_add.js:

TasksController.prototype.override({
    initialize: function ($super, parentEl, params) {
        $super(parentEl, params);
        this.squeezeWindowContent = false;
    }
});

The Material Design skin has a more advanced example, disabling squeezeWindowContent only when the player is visible and on the bottom dock (which is the default state).

barrym

2022-01-21 01:48

reporter   ~0066698

OK, thanks.

"allow the user to right click > Cancel all on the tasks controller on the top bar. This I can do."

This happens after I get 5.0.3? ... ATM (2531) I am unable to cancel a sync using anything at the top (menu bar, Tool bar etc, and the spinning wheel has no Context Menu item to achieve this) , using your new version of Dark Monkey ... Expected?

Am I missing something?

drakinite

2022-02-03 00:05

developer   ~0066826

2531 is a 5.0.2 build. However, the context menu addition in 5.0.3.2603 caused a crash as described in 0018240. Should be resolved in the next build.

barrym

2022-02-03 09:01

reporter   ~0066830

Also can look at the issue I raised here also please; https://www.mediamonkey.com/forum/viewtopic.php?p=494127#p494127

The text in the new Status bar can get overwritten if there is a task running in the background.
I don't know whether this is a framework, or a skin issue ... or is WAD . ?

barrym

2022-02-04 07:39

reporter   ~0066849

drakinite: see my answer to your question here: https://www.mediamonkey.com/forum/viewtopic.php?p=494180#p494180

drakinite

2022-02-06 13:08

developer   ~0066868

Barry has confirmed that it was resolved in 2605.

peke

2022-02-06 19:56

developer   ~0066870

Verified 2605

I can also confirm.