View Issue Details

IDProjectCategoryView StatusLast Update
0018506MediaMonkey 5Help / Docs / Localizationpublic2021-11-06 18:22
Reporterrusty Assigned To 
PriorityurgentSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018506: Skin string tweaks
DescriptionThere are a couple of seemingly unnecessary/duplicate strings introduced in the Material Design skin.

1) Color theme. Is this the same as 'Theme color:' which was already introduced for the groove skin? We should probably just use one or the other.

2) Display size. We can just use 'Size' which already exists.

3) Size strings:
Compact --> Small (already exists)
Normal --> can be left as 'Normal' or 'Default' (whatever you think makes more sense--both already exist)

Note also: I'm not sure if these are set up for localization as I didn't see e.g. 'Color theme' in weblate
TagsNo tags attached.
Fixed in build2516

Relationships

related to 0018449 closeddrakinite Enable skin options via info.json so skin developers don't have to write code 

Activities

drakinite

2021-11-03 12:27

developer   ~0065674

1) Good point.... I think there's a difference between the two. For Material Design, I think "Color theme" applies, because it's a theme based around multiple different colors. But Monkey Groove only uses a single color. Perhaps Monkey Groove's could be changed just to "Color"? The word by itself could prove useful in other contexts in the future.

4) Fixed

rusty

2021-11-03 14:35

administrator   ~0065676

As discussed offline:
We'll use strings for 'Theme' (for MD) and 'Color' (for Groove).

drakinite

2021-11-04 00:10

developer   ~0065696

Fixed in 2515

peke

2021-11-05 00:07

developer   ~0065735

MG Still state "Theme" instead "Color"

peke

2021-11-05 00:07

developer   ~0065736

Bug18506.png (64,528 bytes)   
Bug18506.png (64,528 bytes)   

drakinite

2021-11-05 20:19

developer   ~0065774

Oops - must have been a mistake. Fixed for next build.

peke

2021-11-06 18:22

developer   ~0065777

Verified 2516

All OK now.