View Issue Details

IDProjectCategoryView StatusLast Update
0018474MediaMonkey 5Playlists (Auto) / Search / Filterspublic2022-05-09 13:03
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.3Fixed in Version5.0.2 
Summary0018474: Playback causes contextual search results / and folders element to reset
DescriptionIf the user initiates playback and then initiates a contextual search, then during playback the search results will often reset even though the contextual search term continues to display at the top. e.g.

1 Navigate to Music > Location > Path > Alan Parsons Project > All [List:(folders)]
--> 2 subfolders display (they each contain an album), and the tracks from those folders display below
2 Double-click on the first track to initiate playback
3 Type 'don'
--> filter is activated and shows 3 matching tracks and subfolders are removed from the view
--> a few seconds later, the view switches to displaying all tracks (even though 'don' continues to display in the breadcrumbs)
4 Retype 'don'
--> filter is activated again and shows 3 matching tracks but no subfolders
5 Press NEXT 1x or 2x
--> filter remains activated, and subfolders re-appear
--> Subfolders appear!

https://www.screencast.com/t/gvlmFjHpZ2Ie

tested build 2511
TagsNo tags attached.
Fixed in build2514

Relationships

related to 0018513 resolvedrusty Breadcrumbs sometimes don't collapse 
related to 0019064 closedLudek Podcasts: Updating podcast break inline search 

Activities

Ludek

2021-11-01 16:27

developer   ~0065606

Fixed in 2514

rusty

2021-11-03 20:37

administrator   ~0065685

This is partially fixed in 2514. The view still either sometimes fails to display subfolders OR displays them with a delay:

1 Navigate to Music > Location > Path > Alan Parsons Project > All [List:(folders)]
--> 2 subfolders display (they each contain an album), and the tracks from those folders display below
2 Double-click on the first track to initiate playback
3 Type 'don'
--> filter is activated and shows 3 matching tracks and subfolders -- but the subfolders don't appear immediately, it takes about a second for them to re-appear (minor issue)!
4 Click X to cancel the contextual search and Retype 'don'
--> filter is activated again and shows 3 matching tracks but subfolders are missing from the view!
5 Press NEXT 1x or 2x
--> filter remains activated, and subfolders re-appear

Ludek

2021-11-04 11:51

developer   ~0065717

I can't replicate at all and don't see a reason why subfolders shouldn't appear immediatelly in the step 3

Can you catch this in screencast + log ?

Ludek

2021-11-05 17:21

developer   ~0065762

Last edited: 2021-11-05 17:21

View 2 revisions

The folders didn't appear as they don't include "don" in its name. So that's a test error.

As for the breadcrumbs didn't collapse, I can't replicate, but to be solved in 0018513

rusty

2021-11-05 19:32

administrator   ~0065769

So I guess the issue is step 3 at 0018474:0065685 -- in which the folder appears on a delayed basis even though it doesn't match. However, I can't replicate that, so I'm re-resolving this to be verified by someone else.

peke

2021-11-11 11:50

developer   ~0065844

Verified 2518

It works as fix in 2514 I also can't replicate folder re show delayed.

Closing for now will be retested when testing 0018513