View Issue Details

IDProjectCategoryView StatusLast Update
0018461MediaMonkey 5FileMonitor / Find Missingpublic2021-10-26 18:26
Reporterbarrym Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformWindowsOS-OS Version10
Product Version5.0.2 
Target Version5.0.2 
Summary0018461: Continuous File monitor does not detect all media files
DescriptionI added some folders of new rips to my monitored folder. Some media files were not detected.
* detected successfully if the folder was album with tracks
* not detected if the folder was albumartist\album with tracks

The missing media files were successfully detected via a manual "Scan Now"

If this is WAD, could you consider walking the file hierarchy to a depth that covers that last case?
Tested with flac files on 2511
 
 
Steps To Reproduce1) monitor a folder continuously
2) D&D an albumartist\album folder containing flac tracks at the bottom level
TagsNo tags attached.
Fixed in build

Activities

rusty

2021-10-25 16:54

administrator   ~0065492

Last edited: 2021-10-25 16:55

View 2 revisions

This is definitely not by design, however, I'm unable to replicate this. I tested as follows:

0 Set file monitor to scan Music/Location/DowloadPath continuously and at startup
1 Navigate to Music/Location/DowloadPath [List:All] (i.e. so that subfolder content would display)
2 Using a browser, downloaded an .m4a file to /DowloadPath
--> It didn't appear in Music/Location/DowloadPath [List:All] right away
3 Pressed F5
--> It appeared
4 Using FreeCommander, dragged a file to Music/Location/DowloadPath
--> it appeared in Music/Location/DowloadPath [List:All] right away
5 Using FreeCommander, dragged a directory to /DowloadPath/Sub
--> it appeared in Music/Location/DowloadPath [List:All] right away
6 Switched view to Music/Location/DowloadPath/sub [List] and opened the tree to Music/Location/DowloadPath/sub [List:All|List(Folders)]
7 Using FreeCommander, dragged a directory to /DowloadPath/Sub
--> The new directory appeared in the Tracklist, and a '>' appeared next to /sub in the tree

So unless I'm misunderstanding the report, I'm unable to replicate this (aside from a non-replicable refresh glitch that occurred on one occasion at step 2. If you're able to replicate this can you generate a debug log and re-open?

rusty

2021-10-25 17:00

administrator   ~0065493

Last edited: 2021-10-25 17:06

View 2 revisions

Re-opening. When I re-performed step 7 using a directory containing flac files, the directory and the files failed to appear in MM (even after refreshing). So it appears that the bug is format-specific!

Edit: Moreover flac files didn't appear in MM even when I dragged them directly into /DowloadPath/Sub . i.e. the bug seems to occur for flac files whether copied directly to a monitored folder, or to a subdirectory of a monitored folder).

barrym

2021-10-26 02:27

reporter   ~0065502

OK, but I think my initial issue may have been my error.
I thought that Continuously meant "continuously" ... ie had not noticed the At Startup & Continuously option .. So I am not 100% sure whether I had MM5 running when I added the folders, and possibly the single level folders were a coincidence because MM5 was running at that time. .. ?
Can't replicate this morning.

Ludek

2021-10-26 13:14

developer   ~0065512

Last edited: 2021-10-26 13:15

View 2 revisions

I can't replicate too.

1) Attach debug log of this
2) Verify that the particular FLAC file isn't somehow corrupted and try to scan it manually to MM5 to confirm that MM5 hasn't a general problem scanning this particular FLAC

rusty

2021-10-26 18:26

administrator   ~0065517

Test error. The tracks in question were classical music and that's why they didn't appear in the Collection I was testing.