View Issue Details

IDProjectCategoryView StatusLast Update
0018380MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-10-08 13:13
Reporterpeke Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018380: Mask fields named inconsistently (Title and Artist)
DescriptionTag Names inconsistency can be found in multiple parts of MM.

For example tag "<Artist>" is use everywhere except in >> Menu that should help user create Destination masks and it is classified under "Track Artist" which adds confusion.

I guess expected name should be "Artist (Track)"
TagsNo tags attached.
Fixed in build2508

Activities

peke

2021-10-03 20:40

developer   ~0064964

bug18380.png (124,579 bytes)   
bug18380.png (124,579 bytes)   

barrym

2021-10-04 04:04

reporter   ~0064965

<<< I guess expected name should be "Artist (Track)" >>>

I think that "artist" is preferable.
The base assumption is that everything relates to the track, unless otherwise stipulated.
And the incident that you identify is probably a coding error. Everywhere AFAIK refers to the tag as "track", including the documentation.

rusty

2021-10-08 02:21

administrator   ~0065038

Last edited: 2021-10-08 02:21

View 2 revisions

I agree with Barry, and see two such issues:
1) 'Track Artist' should be 'Artist'
2) 'Track Title' should be 'Title'

I wonder if this was changed at some point in the past so that these fields would appear together, however, the need to group them isn't relevant in MM5 since mask fields are grouped.

Set to 'urgent' on the assumption that this is trivial/low risk.

michal

2021-10-08 06:29

developer   ~0065040

3) also 'Video actors' should be 'Actors'

Fixed in build 2508. It was there from the very beginning of mask control implementation in 2006.

peke

2021-10-08 13:13

developer   ~0065045

Verified 2508

I have not found more that needs to be changed. Reopen if needed.