View Issue Details

IDProjectCategoryView StatusLast Update
0018374MediaMonkey 5Playlistspublic2021-10-08 17:52
Reporterbarrym Assigned To 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS-OS Version10
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018374: MM5 crashes when user creates custom view for a manual playlist (regression)
DescriptionUser is trying to create a Custom view for his manual playlist
MM5 becomes unresponsive with v high cpu
Requires termination by Task Manager

Tested with 2506
Crash logs sent to you
Steps To Reproduce1> Create a normal manual playlist
2> Create a custom view for the playlist, based upon List View, and set sort seq to 1.Artist, 2.Album, 3.Track#
3> Change to a different View, eg List View
4> MM5 is non-responsive, with v high CPU
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=487967#p487967
https://www.mediamonkey.com/forum/viewtopic.php?p=488204
See crash log 000020B0
TagsNo tags attached.
Fixed in build2508

Relationships

related to 0018353 closedpetr Manage Views facility broken when creating View based upon List (by Album) view. 

Activities

barrym

2021-10-02 13:15

reporter   ~0064941

Report Update:
Altered report title to better reflect severity
Added additional step (#3) which is required to trigger the crash.
Attached details of crash log that was dispatched to you.

barrym

2021-10-02 14:02

reporter   ~0064942

After terminating MM5 after it has crashed with this issue, there seems to be a lingering issue which makes MM5 look very laggy when it is restarted. Art acquisition from the cache is very very slow.
nb. at the beginning it looked like I have lost all my art.
It looks like a instance of MediaMonkeyEngine.exe is left running from the instance which crashed.
If I run the crash test twice, I get two invocations of the Engine left running.
This may not be related to the crash, but it certainly looks like it is.

Everything is OK after I crash off the thing that is left running.

Ludek

2021-10-04 15:24

developer   ~0064969

Last edited: 2021-10-04 15:26

View 2 revisions

I can confirm the crash, seems an issue introduced recently (as 2503 works fine) while it crashes on curent sources.

petr

2021-10-04 18:14

developer   ~0064974

Fixed

barrym

2021-10-05 00:21

reporter   ~0064981

Is this the same issue?
Presents differently to the issue I reported earlier, but happens when trying to save a custom View
v2507

petr

2021-10-05 09:30

developer   ~0064982

Yes it is also fixed

peke

2021-10-08 17:52

developer   ~0065066

Verified 2508

Unable to reproduce.