View Issue Details

IDProjectCategoryView StatusLast Update
0018342MediaMonkey 5Extensions frameworkpublic2022-12-01 17:41
Reporterrusty Assigned To 
PriorityurgentSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.2 
Target Version5.1Fixed in Version5.1 
Summary0018342: Addons Dialog actions should be clearer
DescriptionAs described by drakinite, the Addons dialog can be a bit confusing because it mashes up two distinct usecases:
1) Actions on installed addons (i.e. finding updates)
2) Actions related to download and installation of new addons (finding new addons / installing addons from a local directory). Furthermore this set of actions is confusing because it's not clear that addons aren't installable locally.

To improve this, the following changes are suggested:

1) Change 'Find updates' --> 'Check for updates...' (this string already exits).
2) Change 'Get more addons...' --> 'Find more addons...'
3) Change 'Add' --> 'Install addon from file...' and move it to the left side of the dialog to the right of 'Find more addons...' (actions on the left don't apply to the list of installed addons, unlike actions on the right which do.
4) Currently the only action associated with a selected addon would be pressing the DELETE key, however, pressing DELETE has no effect. This should be fixed (or selection should be disabled until it can be fixed)
TagsNo tags attached.
Fixed in build2800

Relationships

related to 0013908 assignedLudek Extensions: Addons Site browsable directly from MMW 

Activities

Ludek

2022-12-01 17:41

developer   ~0070481

Fixed in 5.1.0.2800