View Issue Details

IDProjectCategoryView StatusLast Update
0018329MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-10-08 21:21
ReporterLudek Assigned To 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018329: Continual mass edits can result in crash
DescriptionLog from tickets # 2733 shown that doing this repeatedly can result in "Too many threads for indexing" assertion:

1) Select at least two tracks in file-listing > right-click > Properties
2) Change a field (e.g. comment)
3) Click [OK]

Repeat steps 1-3 hundred times
=> potentialy crash "Too many threads for indexing (do all threads have finalization??)" appears
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=487048#p487048
TagsNo tags attached.
Fixed in build2508

Activities

Ludek

2021-09-21 16:40

developer   ~0064780

Fixed in 5.0.2.2504

Ludek

2021-10-04 14:50

developer   ~0064967

Re-opened: User from [Ticket # 2733] is still able to produce this kind of crash/error, analyzing...

Ludek

2021-10-04 15:42

developer   ~0064970

Problem found and discussing the cause with devs, solution unclear yet though...

Ludek

2021-10-04 19:48

developer   ~0064975

Fixed in 2508

peke

2021-10-08 21:21

developer   ~0065078

Verified 2508

Confirmed fix after 330+ continual Edits