View Issue Details

IDProjectCategoryView StatusLast Update
0018282MediaMonkey 5Collectionspublic2021-10-21 20:58
Reporterbarrym Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformWindowsOS-OS Version10
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018282: "Visible if content exists" doesn't work for "Podcasts" node?
DescriptionThe sub-node remains visible if empty when is half checked in the Media Tree
Works as expected with "TV" and "Classical Music" on the other hand.
And disabling it completely does work OK
Steps To ReproduceHow to reproduce:
- Podcasts: none
- In "Configure collections and nodes" set the "Podcasts" node to: "Visible if content exists"
Result: The "Podcasts" node remains visible although there is no content in it.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=100048
TagsNo tags attached.
Fixed in build2503

Relationships

related to 0017881 feedbackLudek Collection is shown as 'Disabled' even when it is visible 
related to 0018423 closedLudek Rebuild database results in exception (regression 5.0.2.2503) 

Activities

Ludek

2021-09-15 13:31

developer   ~0064646

Fixed in 2503

peke

2021-09-17 23:22

developer   ~0064741

Verified 2503

It works OK for me now.

lowlander

2021-09-21 16:30

developer   ~0064779

Problem persists on 2503:
1 Clean Install
2 Set Podcasts to "visible if content exists"
--> Podcasts still shows
3 Restart MediaMonkey
--> Podcasts still shows
4 Disable Podcasts
--> Podcasts no longer shows
5 Set Podcasts to "visible if content exists"
--> Podcasts shows again

Also happens when setting up a new Collection that has no content due to Criteria.

Ludek

2021-09-22 17:00

developer   ~0064824

Last edited: 2021-09-22 17:02

View 2 revisions

I am unable to replicate after the fix in 2503 :-(

Tested on current sources, but also on 2503 installed as portable (clean install) without importing MM4 settings and entering my license key to edit collection.

Can you please re-test whether it was not just a test error and capture this in screencast video + generate debug log?
Thanks!

lowlander

2021-10-21 20:58

developer   ~0065399

Verified on 2510. Podcasts on a clean install doesn't show, nor do Music and Entire Library as expected as they have no content.