View Issue Details

IDProjectCategoryView StatusLast Update
0018274MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-09-17 16:19
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018274: Cancelling Tagging can introduce discrepancies
DescriptionWhen tagging a large amount of files MediaMonkey will first do the database updates for the files, then do the actual tagging of the files.

When MediaMonkey is doing the database updates the user can cancel. This will cancel the database updates, however MediaMonkey then continues tagging the files requiring a second cancelling of tagging (in MediaMonkey 4 it would be one cancellation that was needed).
Steps To Reproduce1 Tag 1000 files
2 Cancel the update database stage from the progress bar
--> Expected tagging to stop (MediaMonkey 4 behavior)
--> MediaMonkey starts tagging files (all originally updated files).
3 Cancel file tagging

The problem is that the database will have received different updates than the files in this scenario introducing data discrepancies between database and file tags.

Maybe where MediaMonkey updates database for 1 file, then tags the file, then updates database for next file and then tags the file would be preferred. Any cancellation would then be a single cancel and would happen before the next file is updated in the database (so database and file data are in sync).
TagsNo tags attached.
Fixed in build2503

Relationships

related to 0018228 closedLudek Tagging of Comment of large amount of files fails 

Activities

Ludek

2021-09-14 16:24

developer   ~0064613

Last edited: 2021-09-14 16:59

View 3 revisions

Fixed in 2503.

i.e. the tagging thread tags only the files that have been already updated to DB (and were not canceled) -- i.e. only the not canceled DB updates are queued for tagging (though the tagging thread can still be canceled).

Note that in MM4 canceling the DB update thread also did not cancel the tag updating thread.

lowlander

2021-09-17 16:19

developer   ~0064730

Verified on 2503.