View Issue Details

IDProjectCategoryView StatusLast Update
0018266MediaMonkey 5Playlistspublic2021-10-22 12:50
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityunable to reproduce
Status resolvedResolutionunable to reproduce 
Product Version5.0.2 
Target Version5.0.2 
Summary0018266: Files don't remove when Column Filter filters Playlist
DescriptionUser reports that when filtering the Playlist through the Column Filter that multi-file selections fail to delete.
Steps To Reproducehttps://youtu.be/Vyvocgfv_mE
https://youtu.be/Q206lnMxshg
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=100022
TagsNo tags attached.
Fixed in build

Activities

rusty

2021-10-19 18:03

administrator   ~0065323

LL, can you replicate this? I'm not able to in 2510...

lowlander

2021-10-21 20:37

developer   ~0065398

Unable to reproduce on 2510

rusty

2021-10-21 22:14

administrator   ~0065402

Last edited: 2021-10-21 22:41

View 4 revisions

I just observed this earlier today on 2510--but I'm no longer able to replicate it! Peke can you try to figure out how to replicate this?

When I'd observed the issue, the column filter was just enabled but not actually filtering the playlist.

peke

2021-10-22 07:41

developer   ~0065412

Last edited: 2021-10-22 07:48

View 2 revisions

I am not able to replicate 0018266:0065402 behavior but analyzing users Video files I noticed that user is trying to remove tracks from Auto Playlists instead of Static playlists in which case MM behaves correctly.

Only BUG I can see is that User is allowed to press ok if Remove from Playlist only is selected.

This was always like that, assigned to @Ludek for triage. It is long standing issue and it can be pushed if not trivial to disable OK on Auto-Playlists if "Remove from playlist only" is selected.

Ludek

2021-10-22 09:24

developer   ~0065414

Last edited: 2021-10-22 09:24

View 2 revisions

I don't see '(o) Remove from this playlist' choice when removing tracks selected within auto-playlist.

Resolving as "unable to replicate".

Let's re-opend if the issue is re-reported OR we have steps or further info.

peke

2021-10-22 09:45

developer   ~0065416

Last edited: 2021-10-22 09:51

View 2 revisions

As talked offline I was only able to replicate showing remove from Playlist once.

Asked user to supply us MM5.DB and we will try to replicate in latest build by his steps from video.

rusty

2021-10-22 12:43

administrator   ~0065421

Last edited: 2021-10-22 12:50

View 2 revisions

Peke, this bug is when removing files from Playlists (not autoplaylist). It's not DB-specific as both you and I replicated the problem. It more likely has to do with the View/filter/column filter/selection/etc.