View Issue Details

IDProjectCategoryView StatusLast Update
0018203MediaMonkey 5Track Browserpublic2021-10-13 21:31
Reporterpeke Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018203: Online Track Browser: Improved track loading
DescriptionWhen browsing online Artist tracks it is often hard to pinpoint/find specific track.

1. When using online Track Browser, showing all Artist tracks appear frozen during collecting online info. I would suggest that track list is shown in Batches as they are received, not waiting till all are collected.

2. In case of Online Artist page I would prefer that All tracks are by default sorted by title instead of received order
2a. Show more from Youtube eg. tracks (unclassified) also use strange sort (title is 5th subsort) Instead of simpler one
Steps To Reproduce1. Search MM library for artist "Shaggy"
2. Open Artist page
3. Switch to online tab
4. Select Show all tracks instead top tracks
5. Loading All tracks show and there is no progress/working circle beside Loading info and it takes time to show tracks
TagsNo tags attached.
Fixed in build2501

Relationships

related to 0018307 closedmichal Online files Find more from same discrepancy 

Activities

peke

2021-08-16 22:15

developer   ~0064384

bug18203.png (34,471 bytes)   
bug18203.png (34,471 bytes)   

michal

2021-09-08 12:32

developer   ~0064496

Fixed in build 2501. Added progress wheel, but tracklist is not read in batches, it is received at once, the most time consuming is only waiting for server response.
Default sorting of all online tracks changed to title. Youtube tracks are sorted by relevance, as received from Youtube, fixed displaying wrong sort indicators.

lowlander

2021-09-16 18:16

developer   ~0064678

Verified that a progress indicator is shown on 2502:
1) In Info Panel
2) In Statusbar
3) Activity indicator on Toolbar

but progress indicator in Info panel shows 'Getting tracks' instead of 'Getting files'

michal

2021-09-17 20:53

developer   ~0064733

lowlander: why change wording? User presses "Show all tracks", then we fetch info about these tracks, so displaying "Getting tracks" makes sense for me, this string is long time there.

lowlander

2021-10-13 18:45

developer   ~0065177

We're dealing with video files instead of music tracks in this scenario. So using files instead of tracks is more accurate in this context.

rusty

2021-10-13 19:45

administrator   ~0065178

I can't seem to see the progress indicator, but if I'm understanding correctly, we're talking about YT in which case, MM isn't actually getting the files. It's getting the list of tracks. So the current wording is preferable (since 'files' is more concrete than 'tracks').

Nonetheless, I agree that we could do better.

Questions for Michal:
- Is this string used elsewhere (for some reason I can't find the string in weblate--I only found 'Getting' and 'Getting data')?
- If 'Getting' is being combined with 'tracks', then maybe we should switch it to 'Getting+media' or 'Getting+streams' ?
If you prefer to defer this, then close this issue and we'll open a new one to track the remaining item (it's really a separate issue).

michal

2021-10-13 21:11

developer   ~0065181

lowlander: we fetch info about artist tracks from MusicBrainz DB, not video, info about Youtube music video is not contained in the response, it it searched later on demand.

rusty:
- we use separate word "Getting" concatenated with several possible strings (all used in progress text) - "album image", "series image", "artist info", "image", "tracks" and "Series".
- but it is progress text when fetching info about artist tracks, from Tracks table in MusicBrainz DB, tracks is in fact exact word, used also by MusicBrainz.

rusty

2021-10-13 21:31

administrator   ~0065186

So we could use 'track info' (it would be a more apt description). But I don't thing it's really necessary/worth another string.