View Issue Details

IDProjectCategoryView StatusLast Update
0018194MediaMonkey 5Syncpublic2021-08-11 17:11
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.1 
Target Version5.0.2Fixed in Version5.0.1 
Summary0018194: ALAC file synchronized to iPod is not played till the end
DescriptionUser sent us ALAC file, which plays only first 35s of 2:15 length on iPod, when copied by MM5 to the device. The same file copied by iTunes plays correctly till the end.
Additional InformationTicket 2315
TagsNo tags attached.
Fixed in build2433

Relationships

related to 0018195 closedmichal Some ALAC files show incorrect waveform 

Activities

michal

2021-08-11 08:36

developer   ~0064372

Last edited: 2021-08-11 08:38

View 2 revisions

I have reproduced the problem with exactly the same ALAC files on iPod, the one copied by iTunes works, the one by MM5 not. So it seems to be probably problem with some information written to iPod DB by MM.
I have noticed, that files copied by MM have wrong "Added" date, there is always year 2036.

Ludek

2021-08-11 12:39

developer   ~0064373

Last edited: 2021-08-11 12:40

View 2 revisions

Debugging this by comparing iPod databases synced by MM4 versus MM5 and problem is in value sample_count
MM4: https://www.dropbox.com/s/0653wzkbwjt4r2y/Screenshot%202021-08-11%2014.20.43.png?dl=0
MM5: https://www.dropbox.com/s/0653wzkbwjt4r2y/Screenshot%202021-08-11%2014.20.43.png?dl=0

The value is written there in iPod.dll on the line
MHIT.sample_count := max64( _geti64('decodingTotalSamples'), 0);

So it is the decodingTotalSamples property of track that is incorrect in MM5 (resulting in showing also incomplete waveform).
Assigning to Michal to fix.

michal

2021-08-11 17:01

developer   ~0064374

Fixed in build 2433

michal

2021-08-11 17:11

developer   ~0064375

Waveform problem is caused by different plugin, will be fixed as 0018195.