View Issue Details

IDProjectCategoryView StatusLast Update
0018176MediaMonkey 5Playlists (Auto) / Search / Filterspublic2021-09-17 02:27
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018176: Searching for semicolon fails
DescriptionIn MM4 when user input just semicolon into search bar then tracks including semicolon in fields (e.g. as as separator of artist field) were shown.
In MM5 no tracks are shown.

TagsNo tags attached.
Fixed in build2500

Relationships

related to 0018127 closedLudek MediaMonkey 5 Unify ';' and 'OR' operators in searching/filtering 
related to 0009756 closedLudek MediaMonkey 4 Searching for ; semi colon in the Artist/Director field throws SQL error 

Activities

Ludek

2021-07-28 19:29

developer   ~0064317

Fixed in 5.0.2.2500

peke

2021-07-28 21:45

developer   ~0064320

I wound the case when it would fail, which is when Artist contain ";;" in name. If you current manually add ";;" to Artist and then initiate either global search or advanced search (Artist -> Contains -> ;) it will be found as expected

I wonder if for 5.0.2 we can add another criteria (along "contains" and others) named "Multi Value" (or similar and only if there is no new string) as that would clearly filter only tracks that have Multi Value and possibly speed SQL execution internally?

peke

2021-07-28 21:58

developer   ~0064321

bug18176.png (13,451 bytes)   
bug18176.png (13,451 bytes)   

Ludek

2021-07-29 12:17

developer   ~0064325

Last edited: 2021-07-29 12:17

View 2 revisions

Artist contains ";" always fails to show results (also in MM4), because single artist cannot contains semicolon as it is used as multi-value separator.

But in MM4 you could put semicolon into search bar to find tracks with fields including semicolon (be it separator or not).

This was no longer the case in MM5 and is fixed in 5.0.2.2500

peke

2021-07-30 01:31

developer   ~0064331

bug18176_mm4.png (79,790 bytes)   
bug18176_mm4.png (79,790 bytes)   

peke

2021-08-31 21:08

developer   ~0064444

Verified 2500

using ; in search finds Multi Value.

peke

2021-09-17 02:27

developer   ~0064713

Re verified 2502