View Issue Details

IDProjectCategoryView StatusLast Update
0018118MediaMonkey 5Syncpublic2021-07-27 10:21
ReporterLudek Assigned To 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0018118: iPod sync: "TDeviceCalculator.calcfinish: freeSpace < 0!!!" assertion
DescriptionUser at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99490
is experiencing this AV / assertion when syncing iPods.

To find more...
TagsNo tags attached.
Fixed in build2421

Activities

Ludek

2021-07-06 15:19

developer   ~0064160

For 5.0.1.2421 I've disabled the assertion (until I am able to fully analyze or replicate the issue) i.e. once the bug occurs then it won't no longer crash, but just the bottom graphical indicator might show incorrect values

Ludek

2021-07-06 15:26

developer   ~0064161

Last edited: 2021-07-06 15:27

View 2 revisions

OK, I have just replicated and the incorrect values might be there just briefly after connection of the iPod (i.e. no longer crashing in 2421).
Left opened to analyze the cause for the initially incorrect values...

Ludek

2021-07-07 09:41

developer   ~0064173

Fixed

rusty

2021-07-07 13:24

administrator   ~0064178

Verified 2421, but leaving this as 'resolved' since a final fix that resolves the initially incorrect values (in build 2422), should be verified.

peke

2021-07-27 10:21

developer   ~0064300

No issues on my iPod Touch 4G after build 2421. Last version tested 2429.