View Issue Details

IDProjectCategoryView StatusLast Update
0018071MediaMonkey 5Playbackpublic2021-09-17 00:49
Reporterpeke Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018071: Play now Double Click Action is slower comparing to MM4
DescriptionDouble Click Action is slower comparing to MM4

In MM4 when for play now double click user have "Clear playlist, play selected + subsequent" and track browser have 30k+ tracks MM4 firstly add selected track and play it while adding others even UI is frozen for a few seconds (MM5 do not have that issue as we moved it from main thread).

In MM5 with same settings UI is responsive, but in some environments it takes few seconds to player start playing the track.

Personally I avoid having "Clear playlist, play selected + subsequent" as default action but "Clear playlist, play selected only" when playback is stopped and "Play last" when there is playback.

Reason for that is ho I build no playing eg. Select few tracks or playlist and start playback -> use global search to find additional tracks and double click to add them to Now Playing.
Steps To Reproduce1. Have at least 10k tracks in Now playing and MM is playing
2. Make sure that there is at least 10k+ tracks in track browser (the more the better)
3. Make sure that Play now is set to "Clear playlist, play selected + subsequent"
4. Double click on track
5. MM stops playback
6. few seconds later new track starts to play

This delay depends on PC configuration and CPU speed.

I used Ryzen Master to limit CPU cores and CPU speed to be able consistently replicate
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=31&t=99429
TagsNo tags attached.
Fixed in build2500

Relationships

related to 0017501 closedLudek Playback fails to start in some specific cases 
related to 0018091 closedmichal Remove "Show warning when file to be played is not accessible" option 

Activities

Ludek

2021-06-28 14:44

developer   ~0064088

I am unable to replicate, double-clicking track in the Music > All tracks (12616 tracks ), can you please:

1) verify whether this settings has any impact on the issue:
Options > Player > Auto-DJ / Playing list
[x] Show warning when file to be played is not accessible

2) Generate debug log (item 4b here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=86643 )

michal

2021-06-28 14:57

developer   ~0064089

I cannot reproduce too, tested with tracklist with over 280 thousands (!) files, playback started till 0.5s.

peke

2021-06-29 00:01

developer   ~0064095

I can confirm same behavior as user at https://www.mediamonkey.com/forum/viewtopic.php?p=483523#p483523

Having "Show warning when file to be played is not accessible" enabled causes random lag before playback, depending on number of tracks.

Good catch, I have that option enabled for years and wwould never thought it can cause problems.

Ludek

2021-06-29 11:37

developer   ~0064100

The user from the forum confirmed that the issue appears only with
Options > Player > Auto-DJ / Playing list
[x] Show warning when file to be played is not accessible

michal

2021-07-01 09:44

developer   ~0064133

Fixed in build 2500 by removing this depricated option in 0018091.

peke

2021-09-17 00:49

developer   ~0064691

Verified 2502

MM5 is now faster than MM4 on large track now playing operation.