View Issue Details

IDProjectCategoryView StatusLast Update
0018064MediaMonkey 5Syncpublic2021-08-30 10:32
ReporterLudek Assigned To 
PriorityimmediateSeverityblockReproducibilityhave not tried
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0018064: Sync stalls with "Waiting for file to convert" once 50 tracks have been already pre-converted (regresison 5.0.1)
DescriptionWhile fixing 0013498:0045645 (and introducing the 50 pre-converted tracks limit during USB sync) the Wi-Fi sync now stalls after 50 converted and downloaded tracks!
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=483356#p483356
https://www.mediamonkey.com/forum/viewtopic.php?f=26&t=99405
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=99768

Ticket 2355 2364
TagsNo tags attached.
Fixed in build2432

Relationships

related to 0013498 closedLudek Device sync: Our reservation isn't always enough when auto-conversion is faster than copying 
related to 0018230 resolvedLudek Sync to Local storage (folder) may hang 

Activities

Ludek

2021-06-24 17:19

developer   ~0064060

Fixed in 2419

peke

2021-06-25 22:26

developer   ~0064076

Verified 2419

Unable to replicate in current version.

Ludek

2021-08-09 14:45

developer   ~0064360

Last edited: 2021-08-09 14:48

View 2 revisions

Re-opened:
This is still issue for user 'cosmicknowledge' and 'viking74' here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99515&start=15
And users 'ssawyer' and 'JensFF' here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99706 + [Ticket # 2292]

Based on the log from [Ticket # 2292] I see where the problem lies.

The issue is reproducible when the conversion is faster than copying (to have at least 50 files pre-converted), workaround can be lowering number of threads in Options > Performance > Auto-conversion

Ludek

2021-08-09 14:56

developer   ~0064361

Last edited: 2021-08-09 15:03

View 3 revisions

Fixed in 5.0.2.2500

As the fix is low risk and as the issue may affect a number of users I merged the fix also to the 5.0.1 branch -- so it might worth to re-release 5.0.1 ?
Or at least create 5.0.1.2432 test build for the affected users to confirm the fix.

Ludek

2021-08-30 10:32

developer   ~0064416

Closing, though there is still instance of this issue for the 'Local storage (folder)' sync, tracked+fixed as 0018230