View Issue Details

IDProjectCategoryView StatusLast Update
0018037MediaMonkey 5Conversion/Levelingpublic2021-06-21 08:12
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0018037: Automated volume leveling: no status indicator displayed / crash (regression)
DescriptionIf the user enables automated volume leveling, the status indicator may display initially, but if the user restarts MM when some tracks have not yet been analyzed, then no status indicator appears. Moreover, when MM is then closed, it crashes.

Tested with build 2416

Steps To Reproduce0 Enable automated volume analysis
1 Scan a bunch of tracks
--> Volume analysis proceeds and an hourglass may display
2 Restart MM before all tracks have been analysed
--> Volume analysis resumes, but there's no indication in MM of this!
3 Try to close MM
--> Terminate existing processes dialog appears! (this is confusing because the user doesn't see any processes running)
4 Terminate processes
--> NTDLL error (no crashlog)
TagsNo tags attached.
Fixed in build2417

Relationships

related to 0017679 feedbackrusty Status displays inconsistently / Hourglass appears but Status bar doesn't open for some background processes 
related to 0018053 closedmichal Volume Leveling leaves an infinite process running (regression 2417) 

Activities

rusty

2021-06-17 03:58

administrator   ~0063964

A crash occurred again, this time with a crashlog. I've shared the crashlog and debuglog to the ftp.

rusty

2021-06-17 04:02

administrator   ~0063965

Note: the crash is no longer occurring on close, so I suspect that it's because thumbnails have all been generated (i.e. it only occurs when thumbnails are being generated and (automated?) volume analysis is ongoing.

michal

2021-06-17 09:31

developer   ~0063967

Last edited: 2021-06-17 09:31

View 2 revisions

Indicator fixed in build 2417. I cannot reproduce the crash and the log shows, that it was crash inside Eureka, so hard to say what exactly was the cause. Please retest after the fix.

rusty

2021-06-17 22:58

administrator   ~0063976

Verified 2417 (status is shown, and no crashing on exit).