View Issue Details

IDProjectCategoryView StatusLast Update
0018032MediaMonkey 5Playbackpublic2021-10-22 15:42
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018032: Preview window can shrink too much causing Artwork and Video artifacts
DescriptionIf the user shrinks the vertical space of the preview window so that it's less than 225 pixels high, then:
- The bottom of Artwork in the Preview window is cut off
- Videos playing in the Preview window extend below the bottom margin of the preview window, resulting in about 20 pixels of Video playing in the player portion of the UI (instead of in the Preview window).
Steps To Reproduce1 Set Preview window to 225x225
2 Initiate playback of a MusicFileA followed by videoFileB
--> Music file artwork displays in the preview Window as expected
3 Try to shrink the vertical size of the Preview window by dragging it's Title bar down
--> it can't shrink below the minimum size (as designed)
4 Try to shrink the vertical size of the Preview window by shrinking the size of the MM window
--> The Preview window cuts off part of the Artwork!!
5 Resize the Preview window to 225x225 and Click NEXT to play the video
--> Video file artwork displays in the preview Window as expected
6 Try to shrink the vertical size of the Preview window by dragging it's Title bar down
--> it can't shrink below the minimum size (as designed)
7 Try to shrink the vertical size of the Preview window by shrinking the size of the MM window
--> The Preview window shrinks! And the video displays over the Player!!
Additional InformationSee video: https://www.screencast.com/t/GmYJb3Fo
TagsNo tags attached.
Fixed in build2511

Activities

michal

2021-06-15 08:31

developer   ~0063942

It happens, because there is not enough vertical space for all controls, and video window is always above application window, it cannot be partially hidden.
The only solution is to increase minimal size of the window based on current layout.

michal

2021-10-21 15:07

developer   ~0065375

Fixed in build 2511.

peke

2021-10-22 15:42

developer   ~0065428

Verified 2511

Unable to replicate, minimal size is increased so maybe that is the reason for it.